Closed Bug 647236 Opened 12 years ago Closed 12 years ago

Provide a visual indicator for active downloads

Categories

(Firefox :: Toolbars and Customization, enhancement)

4.0 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 564934

People

(Reporter: lech, Unassigned)

Details

(Whiteboard: [bugday-20110401])

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Provide a better visual indicator for active downloads in the toolbar with a count or something to show transfers in progress.

Reproducible: Always

Steps to Reproduce:
1. Find some large file(s) to download.
2. Select and begin downloading
3. Try to find a count or progress status outside of the task bar indicator.
Actual Results:  
Progress is vaguely displayed in the taskbar entry (in Windows 7, not sure about Vista) for Firefox 4. There's really no way to indicate how many downloads are currently transferring or an ETA given for any downloads.

Expected Results:  
The downloads button could behave in a similar fashion to how the current stop/reload buttons behave when placed in the tool bar. With a small animation (loading or otherwise) to indicate a transfer is in progress. A small numerical indicator could also be added as an overlay to the number of downloads in progress.

Other thoughts would be to also display a tooltip when hovering the downloads button which quickly lists the number of active transfers with a complete ETA. Alternately (in Windows 7) a jump menu shortcut for the Firefox entry could be added when a file is being transferred to open the downloads window.
Version: unspecified → 4.0 Branch
Severity: minor → enhancement
OS: Windows 7 → All
Hardware: x86 → All
Whiteboard: [bugday-20110401]
Should be covered by Bug 564934.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: DownloadsPanel
You need to log in before you can comment on or make changes to this bug.