Closed Bug 647315 Opened 9 years ago Closed 9 years ago

Black bars or duplicated chunks randomly appear, when e.g. scrolling TBPL or near the middle of very long pages

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla5
Tracking Status
blocking-fx --- ?

People

(Reporter: dholbert, Assigned: roc)

References

()

Details

(Keywords: regression)

Attachments

(7 files)

Attached video screencast of bug
I don't have concrete STR yet (and this is somewhat low-frequency), but I've been seeing weird black bars when interacting with TBPL in today's nightly.  Usually I hit it when scrolling, but I've also seen it from non-scrolling activities, like clicking on a build letter and then clicking away.

See attached screencast.

josh says he's seen similar stuff too, on mac.
I'm running:
Mozilla/5.0 (X11; Linux x86_64; rv:2.2a1pre) Gecko/20110401 Firefox/4.2a1pre
Ubuntu 10.10 w/ compiz
Note: Attached screencast is with a fresh profile -- so this isn't due to any broken state in my profile.
Yeah, I see this too on a Mac OS X 10.6 machine. Showed up in today's nightly build.
Got repro steps. Not 100% repro, but over 50% of the time. On Mac OS X it happens when I scroll long pages with the scrollwheel when the find-in-page bar is open on the bottom of the window.

Go to this page, probably any tall page will work though:

http://news.ycombinator.com/item?id=2393976

Do a find-in-page for a phrase that doesn't exist, leave the find-in-page bar open. Scroll quickly down and up the page with the scrollwheel. If that doesn't work, try closing the find bar and opening it again and scrolling.
That reproduced it for me the second time I tried.

I also hit a related (I think?) issue where chunks of the page get duplicated after I scroll.  This screencast demonstrates that - I scroll down, then back up, and there's a small chunk of duplicated content at the bottom ("1 point by gnufs 16 hours ago | link").

At the very end of this screencast, I click outside the window, which triggers a full invalidate & cleans up the duplication.
Assuming that this is new in today's nightly (haven't absolutely verified, but am assuming based on me & josh first encountering this today), the regression pushlog would be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e38b294f02c5&tochange=1a89509e25e4
which includes a number of different layers-related changes from roc.  I'd guess that this is from one of those changes.
Duplicate of this bug: 647327
(In reply to comment #5)
> Assuming that this is new in today's nightly

Just confirming this -- I just tried scrolling at josh's URL in yesterday's nightly (20110331) side-by-side with today's nightly (20110401).  I could easily repro screencast 2 with today's nightly, but couldn't repro with yesterday's.
Summary: Black bars randomly appear, when e.g. scrolling TBPL → Black bars randomly appear, when e.g. scrolling TBPL or near the middle of very long pages
Summary: Black bars randomly appear, when e.g. scrolling TBPL or near the middle of very long pages → Black bars or duplicated chunks randomly appear, when e.g. scrolling TBPL or near the middle of very long pages
I cannot repro this issue. I've tried with the latest nightly and now I'm using an hourly build (cd525fb68574). Windows 7 Pro x64 SP1 with dual ATI HD5770s in Crossfire mode and the latest Cat 11.3 drivers and profiles.
blocking-fx: --- → ?
I could also reproduce this on my work machine today, win7 SP1, d3d10.  More specific pushlog:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c0564f7efcb9&tochange=839c87b7e4bb
If this helps I did some regression testing on XP Pro SP3 (VIA Chrome9 Integrated Graphics):

Good: Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre
Firefox/4.2a1pre ID:20110331141043

Bad: Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre
Firefox/4.2a1pre ID:20110331153319

The changeset for the bad build is: changeset - 64548:839c87b7e4bb
Here is a screenshot of latest hourly with clean profile.
I can reproduce on VMWare Player(Host OS windows7/ Guest OS windows XP).
http://hg.mozilla.org/mozilla-central/rev/1a89509e25e4
Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110401 Firefox/4.2a1pre ID:20110401030438

Regression pushlog;
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c0564f7efcb9&tochange=69a9aa30f2ef

[STR]
1. Start Minefield woth new profile.
2. Make sure browser is in normal mode
3. Load URL https://bugzilla.mozilla.org/show_bug.cgi?id=647315
4, Expand width of browser till horizontal scroll bar disappears if necessary.
5. Reduce width of browser till horizontal scroll bar appears
6, Scroll up and down by thumb of scrollbar (or Mouse wheel)

Graphics
   Adapter Description: VMware SVGA II
  Vendor ID: 15ad
  Device ID: 0405:
  Adapter RAM: Unknown
  Adapter Drivers: vmx_fb
  Driver Version: 11.6.0.35
  Driver Date: 4-21-2010
  Direct2D Enabled: Blocked on your graphics card because of unresolved driver issues.
  DirectWrite Enabled: false (0.0.0.0, font cache n/a)
  WebGL Renderer: (WebGL unavailable)
  GPU Accelerated Windows: 0/1
In addition to Comment #13
It happens on Windows 7 with STR if disabled Hardware acceleration

http://hg.mozilla.org/mozilla-central/rev/1a89509e25e4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110401 Firefox/4.2a1pre ID:20110401030438

Graphics
  Adapter Description: ATI Radeon HD 4300/4500 Series
  Vendor ID: 1002
  Device ID: 954f
  Adapter RAM: 512
  Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  Driver Version: 8.831.2.0
  Driver Date: 3-8-2011
  Direct2D Enabled: false
  DirectWrite Enabled: false (6.1.7601.17563, font cache n/a)
  WebGL Renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
  GPU Accelerated Windows: 0/1
I would suspect 635373 except that that should not have affected non-accelerated layers.
Duplicate of this bug: 647451
Able to reproduce with build http://hg.mozilla.org/mozilla-central/rev/1a89509e25e4 on the page mentioned in comment #3.

Mac OS X 10.6.7

  Chipset Model:	NVIDIA GeForce 9400M
  Type:	GPU
  Bus:	PCI
  VRAM (Total):	256 MB
  Vendor:	NVIDIA (0x10de)
  Device ID:	0x0863
  Revision ID:	0x00b1
  ROM Revision:	3385
> I would suspect 635373 except that that should not have affected
> non-accelerated layers.
In local build,
build from 844579d34200 : fails
build from 4096a34495a5 : works
Triggered by:
844579d34200	Robert O'Callahan — Bug 635373. ThebesLayerOGL needs to make sure we only sample valid pixels too. r=mattwoodrow(In reply to comment #15)
Blocks: 635373
Duplicate of this bug: 647514
Attached image Screenshot
black vertical bar and repainting issue appears when I scroll horizontally with HA off.
I can reproduce this on any page that allows scrolling:

1. Go to such a page, make sure is loaded completely
2. Open find-bar, addon-bar, resize the window or anything else that decreases 
   the size of the viewport. Also happens when scrollbars that are added after 
   page is rendered.
3. Start scrolling and the black bars will appear.

Seems like layers (?) don't play nice when the viewport size is reduced after the initial rendering of the page. 


This will not occur when the viewport is made bigger, nor will it occur if you go to another tab and back again.

(tested with h/w accel enabled on OS X)
Attached patch fixSplinter Review
This should fix it. The changes to non-accelerated code in changeset 844579d34200 were minor, but I did remove the setting of destBufferRect in the case where we have to allocate a new buffer because a rotation prevents a self-copy. That was a mistake; destBufferDims can be smaller than destBufferRect if we thought we were going to reuse the buffer, so we end up thinking the buffer covers a larger area than its actual size, almost certainly causing this bug. So we can just back out the removal of that one line.
Assignee: nobody → roc
Attachment #524152 - Flags: review?(matt.woodrow+bugzilla)
Attachment #524152 - Flags: review?(matt.woodrow+bugzilla) → review+
Attachment #524154 - Flags: review?(matt.woodrow+bugzilla) → review+
Whiteboard: [needs landing]
http://hg.mozilla.org/mozilla-central/rev/a9bb55a25b8c
http://hg.mozilla.org/mozilla-central/rev/18c60f250f9f
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing]
Target Milestone: --- → mozilla2.2
Duplicate of this bug: 648180
blocking2.0: --- → Macaw+
This doesn't transplant :-(

And, I don't see why we would need this in Macaw. From my reading the bug that caused this (bug 635373 according to comment 18) didn't even make it in Firefox 4.

Because of those above two items we are pulling out of Macaw.
blocking2.0: Macaw+ → ---
You need to log in before you can comment on or make changes to this bug.