Live bookmark fails to load if network connection is available *after* firefox launch

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Raj, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

If firefox is launched when no network connection is available, and later if I connect to a network, Live bookmarks fail to load until firefox is restarted

Reproducible: Always

Steps to Reproduce:
1. Ensure no network connections are available
2. Launch firefox
3. Connect to a network
4. Check your live bookmarks
Actual Results:  
In the drop down, you would see 'Live bookmark feed failed to load'. Try to refresh. Still it shows the same error

Expected Results:  
Live book mark refresh should happen successfully

None
(Reporter)

Comment 1

7 years ago
Forgot to mention one point. Normal browsing happens fine. No problems there. It's just that Live bookmarks do not refresh. If i click on existing stale entries of the live feed, it connects fine.

Updated

7 years ago
Version: unspecified → 4.0 Branch
Bug 410101 related?
Component: General → Bookmarks & History
QA Contact: general → bookmarks
I suspect here the problem is not that the feed fail to load, but that we were not removing the "Live bookmark feed failed to load" message correctly.
bug 663104 should have taken care of that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Depends on: 663104
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.