Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Using Print and Print Preview, FF freezes for certain settings in Page Setup on certain sites.

RESOLVED WORKSFORME

Status

()

Core
Layout: Floats
--
critical
RESOLVED WORKSFORME
6 years ago
a year ago

People

(Reporter: christian.zier, Unassigned)

Tracking

({hang, regression})

Trunk
mozilla2.0
hang, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110322 Firefox/4.0 Iceweasel/4.0
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110322 Firefox/4.0 Iceweasel/4.0

FF freezes when trying to print or print preview with
the settings
	File | Page Setup -> Landscape, (US-Letter, A4)
e.g. on the page
	http://www.mozilla-europe.org/en/firefox/features/

On other pages like
https://addons.mozilla.org/en-US/firefox/
http://www.mozilla-europe.org/en/press/2011/03/29/1429-mozilla-launches-firefox-4-for-android
it works, though.

However, with the settings
	File | Page Setup -> Landscape, (US-Legal, A5)
also the page indicated above doesn't cause any problems. 
Other formats than those used above have not been tested.


Reproducible: Always

Steps to Reproduce:
1. Use settings "landscape" and paper format "US-Letter" or "A4".
2. Visit page http://www.mozilla-europe.org/en/firefox/features/
3. Then try to print the page or print preview.

Actual Results:  
FF freezes.

Expected Results:  
To print the page or preview.

Comment 1

6 years ago
Confirmed on Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110404 Firefox/4.2a1pre

Comment 2

6 years ago
Regression window1:
Works:
http://hg.mozilla.org/mozilla-central/rev/373d1b393f28
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100805 Minefield/4.0b4pre ID:20100805200154
Fails Crash:
http://hg.mozilla.org/mozilla-central/rev/8ab7ef79b673
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100805 Minefield/4.0b4pre ID:20100805224228
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=373d1b393f28&tochange=8ab7ef79b673

Regression window2:
Fails Crash:
http://hg.mozilla.org/mozilla-central/rev/c8e72631d44b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110111 Firefox/4.0b10pre ID:20110111165601
Fails Hang:
http://hg.mozilla.org/mozilla-central/rev/b6f7632f63b7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110111 Firefox/4.0b10pre ID:20110111171558
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c8e72631d44b&tochange=b6f7632f63b7
Status: UNCONFIRMED → NEW
Component: General → Print Preview
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → printing
Target Milestone: --- → mozilla2.0
Version: unspecified → Trunk

Updated

6 years ago
Severity: normal → critical
Keywords: regression

Updated

6 years ago
Blocks: 563584, 595740

Comment 3

6 years ago
David, this looks like your stuff.
Component: Print Preview → Layout: Floats
QA Contact: printing → layout.floats

Updated

5 years ago
Keywords: hang

Comment 4

a year ago
Firefox is not freezing when entering the print preview mode on the provided pages. 
The browser changed since this was reported and I don't know if there is a way to set the page layout and paper format before entering print preview. Considering these I will close the bug. If anyone can still reproduce the issue feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.