history untouched to reflect URLs reloaded via session restore on restart

RESOLVED DUPLICATE of bug 613126

Status

SeaMonkey
Session Restore
RESOLVED DUPLICATE of bug 613126
7 years ago
a year ago

People

(Reporter: Felix Miata, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0b13pre) Gecko/20110327 SeaMonkey/2.1b3pre
Mozilla/5.0 (X11; Linux i686; rv:2.0b11) Gecko/20110209 Firefox/4.0b11 SeaMonkey/2.1b2

To reproduce:
1-Set restore previous session on startup in prefs
2-Load multiple URLs in each of multiple tabs
3-Wait at least 24 hours before closing browser (I typically restart at 6 day intervals on OS/2, two weeks or more on Linux)
4-Restart browser
5-Open history and inspect items in the tabs opened on restore

Actual behavior:
1-Timestamps on restored URLS are at least 24 hours old
2-Many recently loaded URLs do not top history sorted by last visited descending

Expected behavior:
1-Timestamps on restored URLs are virtually current
2-All recently loaded URLs do top history sorted by last visited descending

Comment:
This behavior allows URLs repeatedly accessed via the restored tabs to eventually expire from history in spite of frequently having been loaded on browser startup.
Component: History: Global → Places
Product: Core → Toolkit
QA Contact: history.global → places
I think this is WONTFIX.  Session restore is meant to be loading your previous session, not revisit everything.
Component: Places → Session Restore
Product: Toolkit → Firefox
QA Contact: places → session.restore
Version: unspecified → Trunk
(Reporter)

Comment 2

7 years ago
1-What to you mean by "revisit everything"?

2-The first lines in comment 0 were put there to indicate I was describing SeaMonkey behavior, not Firefox behavior. Note Firefox doesn't even display timestamps by default, and calls history "Library", unlike SeaMonkey, which calls History "history".

3-How can it possibly be OK for pages loaded on sequential starts to be allowed to expire from history just because they were conveniently (re)loaded by having been left loaded on exit? Put another way, what I see in the viewport when my browser is started may or may not be current due to caching, but it's nevertheless put in the viewport on whatever date I start the browser, not some date days, weeks or even months previously. If history doesn't reflect that it was put there today, since the browser was opened today, and as opposed to some previous day, week or month, it's perverting the implication of the "last visited" column heading, and the meaning of the window title "History".
Component: Session Restore → Session Restore
Product: Firefox → SeaMonkey
QA Contact: session.restore → session.restore

Comment 3

7 years ago
Felix. Much of the Session Restore functionality is pretty much identical to that in Firefox. Think of it as a "time machine" for tabs.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 613126
You need to log in before you can comment on or make changes to this bug.