When <select> element has size=3, the scroll thumb is not displayed

RESOLVED INVALID

Status

()

Core
Widget: Win32
RESOLVED INVALID
7 years ago
2 years ago

People

(Reporter: Nikki Alex, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

When using <SELECT size="3"> with more than 3 options, the scroll thumb will not display.  This previously worked with Firefox 3.6 but fails consistently on Firefox 4 on Windows XP.

Reproducible: Always

Steps to Reproduce:
1. Create basic html file with Select options of more than 3.  Set <SELECT size=3">.

2.Run on Windows XP machine with Firefox 4.  
Actual Results:  
The scroll thumb will not display for size=3.

Expected Results:  
Visible scroll thumb
(Reporter)

Comment 1

7 years ago
Created attachment 524182 [details]
<SELECT> test case
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110404 Firefox/4.2a1pre ID:20110404030429

A Regression Range would be nice: http://harthur.github.com/mozregression/
Status: UNCONFIRMED → NEW
Component: General → Layout: Form Controls
Ever confirmed: true
Keywords: regression, testcase
Product: Firefox → Core
QA Contact: general → layout.form-controls
Version: unspecified → Trunk
Indeed, especially because I can't reproduce (on Mac, though).
Last good nightly: 2009-08-23 First bad nightly: 2009-08-24

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=30ead1e19478&tochange=45c8ca4ab959

Per Bug 502292 intended Behavior?
Blocks: 502292
Component: Layout: Form Controls → Widget: Win32
QA Contact: layout.form-controls → win32
Created attachment 524206 [details]
Screenshot showing the Issue + Comparison

Trunk - GC 12 - Opera 11 in Comparison on WinXP using Royal Theme.
> Per Bug 502292 intended Behavior?

Seems to be, yes....

Comment 7

2 years ago
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID 	20160524073714

Closing as Invalid based on comment 6. I've also tested with the provided testcase and other browsers do the same (Chrome, IE8, Opera).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.