[PATCH] variable not initialized

RESOLVED DUPLICATE of bug 632352

Status

RESOLVED DUPLICATE of bug 632352
8 years ago
8 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Lightning 1.0b2
x86
Windows CE

Details

(Reporter)

Description

8 years ago
[cave] just came into IRC to report the following issue:


diff -r 2d9cfe35a611 calendar/providers/caldav/calDavCalendar.js
--- a/calendar/providers/caldav/calDavCalendar.js       Tue Mar 29 22:45:57 2011 +0200
+++ b/calendar/providers/caldav/calDavCalendar.js       Wed Apr 06 23:12:06 2011 +0200
@@ -847,7 +847,7 @@
             // TODO As soon as we have activity manager integration,
             // this should be replace with logic to notify that a
             // certain event failed.
-            cal.WARN("Failed to parse item: " + response.toXMLString());
+            cal.WARN("Failed to parse item: " + calData);
             return;
         }
         // with CalDAV there really should only be one item here



response is not initialized in that function I guess. This issue breaks loading from a calendar where events do not parse properly.

Thanks [cave].
I believe a fix for this is pending in a different bug, thanks for reporting it though!
Will be fixed by bug:
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 632352
You need to log in before you can comment on or make changes to this bug.