Cache bootstrap.js scripts

RESOLVED DUPLICATE of bug 648125

Status

()

RESOLVED DUPLICATE of bug 648125
8 years ago
5 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ts])

(Reporter)

Description

8 years ago
Currently we use loadSubScript which doesn't cache the parsed JS like XUL JS is. We could save startup time by doing this.
(Reporter)

Updated

8 years ago
Whiteboard: [ts]
(Reporter)

Updated

8 years ago
Depends on: 648125
I'd also like to see these loaded into BackstagePass globals rather than Sandboxes, along with a requisite way to create said globals from JS. Sandboxes come with too much baggage, including a needless array of proxies for objects which pass in or out of them (and break things like E4X).
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> I'd also like to see these loaded into BackstagePass globals rather than
> Sandboxes, along with a requisite way to create said globals from JS.
> Sandboxes come with too much baggage, including a needless array of proxies
> for objects which pass in or out of them (and break things like E4X).

Should file a new bug about that, I wasn't really aware of any of those issues.
(In reply to comment #2)
> Should file a new bug about that, I wasn't really aware of any of those
> issues.

Dave, do you mean Kris or yourself?
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Should file a new bug about that, I wasn't really aware of any of those
> > issues.
> 
> Dave, do you mean Kris or yourself?

Kris should
Created bug 665810

Comment 6

7 years ago
Bug 648125 caches all scripts loaded by loadSubScript.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648125

Updated

5 years ago
No longer depends on: 648125
You need to log in before you can comment on or make changes to this bug.