Closed Bug 648268 Opened 9 years ago Closed 9 years ago

XML "Undefined entity" error page shown for entity "remoteXUL.title" in netError.xhtml, if no connection can be established

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: aryx, Assigned: wesj)

References

Details

(Keywords: l12y, Whiteboard: [strings])

Attachments

(2 files)

Mozilla/5.0 (Android; Linux armv7l; rv:2.2a1pre) Gecko 20110406 Firefox/4.2a1pre Fennec/4.1a1pre
Android 2.3.3, Nexus S

When only using wifi for connecting to the internet and being out of reach from the access point, Fennec shows a yellow 'Undefined entity' error page:

XML Parsing Error: undefined entity
Location: jar:file:///data/app/org.mozilla.fennec-1.apk!/chrome/toolkit/content/global/netError.xhtml
Line Number 331, Column 31:

<h1 id="et_remoteXUL">&remoteXUL.title</h1>
----------------------^
STEPS TO REPRODUCE:
 1. Enter 'airplane mode'. (or: disable wifi & disable data)
 2. Open Fennec & visit any remote URL. (e.g. http://google.com )

ACTUAL RESULTS: as described in comment 0 & attached photo

I hit this bug in yesterday's fennec nightly (20110406).
Duplicate of this bug: 648287
When this bug is fixed please confirm the fix for bug 648287, as bug 648287 does not have to do with no connections.
alternate str: visit any nonexistent domain, e.g. http://$$$$.com
Looks like this entity is just undefined in the mobile en-US neterror DTD.

An different entity from neterror.xhtml "malformedURI.title" finds hits in /browser, /dom, and /mobile:
http://mxr.mozilla.org/mozilla-central/search?string=malformedURI.title&find=netError.dtd&findi=&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central
...but the same search for remoteXUL.title only finds hits in /browser and /dom:
http://mxr.mozilla.org/mozilla-central/search?string=remoteXUL.title&find=netError.dtd&findi=&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central
This string was added just a few days ago (on 4/6), and it looks like it was just missing the change to the mobile dtd.

Mounir, see Comment 6.
Blocks: 625760
Summary: Undefined entity error in netError.xhtml, shown if no connection can be established → XML "Undefined entity" error page shown for entity "remoteXUL.title" in netError.xhtml, if no connection can be established
Keywords: l12y
Whiteboard: [strings]
(In reply to comment #7)
> This string was added just a few days ago (on 4/6)
(in bug 625760)
Taknig this. I will clean my mess.
Assignee: nobody → mounir.lamouri
Attached patch PatchSplinter Review
Attachment #524749 - Flags: review?(mark.finkle)
Comment on attachment 524749 [details] [diff] [review]
Patch

looks ok to me
Attachment #524749 - Flags: review?(mark.finkle) → review+
Attachment #524749 - Flags: feedback?(mounir.lamouri)
Attachment #524749 - Flags: feedback?(mounir.lamouri) → feedback+
Assignee: mounir.lamouri → wjohnston
Status: NEW → ASSIGNED
Pushed:
http://hg.mozilla.org/mozilla-central/rev/2a91bbaebd77
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Mozilla /5.0 (Android;Linux armv7l;rv:2.2a1pre) Gecko/20110408 Firefox/4.2a1pre Fennec /4.1a1pre
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:2.2a1pre) Gecko/20110411
Firefox/4.2a1pre Fennec /4.1a1pre

Device: Motorola Droid 2 (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.