provide a way to open new tabs next to current tab, instead of at the end of all tabs

RESOLVED DUPLICATE of bug 565549

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 565549
7 years ago
7 years ago

People

(Reporter: Chaitanya, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

suppose there are some 30 tabs open in your window, and you happen to be working in 3rd tab. If you want a new tab, it opens all the way at the end of tab-bar, forcing you to scroll to it, and then scroll back all the way. 

Please provide a way to open new tab after the current one. A setting like 'browser.tabs.insertRelatedAfterCurrent' would be great.

Reproducible: Always

Steps to Reproduce:
1. Open 'n' tabs, where n is a number that necessitates horizontal scrolling across tab-bar 
2. Switch to first tab.
3. Open new tab. This forces you to scroll all the way to the end of tab bar, and scroll back again, when needed.
Actual Results:  
need a way to force new tabs open next to current one

Expected Results:  
need a way to force new tabs to open next to current one

Comment 1

7 years ago
Duplicate of this bug?

Bug 565549 - Opening tabs at the end when new and next to when context-triggered is confusing — consolidate
(Reporter)

Comment 2

7 years ago
seems so to me.
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> seems so to me.

Note that, I am perfectly fine with links opening next to current tab; I want new tabs to open the same way as well. :)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565549
You need to log in before you can comment on or make changes to this bug.