Last Comment Bug 648485 - Intermittent failure in content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
: Intermittent failure in content/base/test/test_bug482935.html | Received fres...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Bjarne (:bjarne)
:
: Andrew Overholt [:overholt]
Mentors:
: 650132 (view as bug list)
Depends on:
Blocks: 438871 482935
  Show dependency treegraph
 
Reported: 2011-04-07 22:27 PDT by :Ehsan Akhgari (in Taipei, laggy response time)
Modified: 2012-11-25 19:31 PST (History)
7 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Changes setTimeout to executeSoon [checked-in] (2.61 KB, patch)
2011-04-08 11:50 PDT, Mounir Lamouri (:mounir)
ehsan: review+
Details | Diff | Splinter Review
Second attempt [checked-in] (4.20 KB, patch)
2011-04-11 22:50 PDT, Mounir Lamouri (:mounir)
ehsan: review+
Details | Diff | Splinter Review
Using asynchronous xhrs instead of synchronous (1.58 KB, patch)
2011-04-20 05:58 PDT, Bjarne (:bjarne)
ehsan: review+
sayrer: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description User image :Ehsan Akhgari (in Taipei, laggy response time) 2011-04-07 22:27:12 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1302227102.1302229749.31490.gz
Rev3 MacOSX Leopard 10.5.8 cedar debug test mochitests-1/5 on 2011/04/07 18:45:02

25764 INFO TEST-START | /tests/content/base/test/test_bug482935.html
++DOMWINDOW == 17 (0x1c916148) [serial = 540] [outer = 0x1c155da0]
25765 INFO TEST-PASS | /tests/content/base/test/test_bug482935.html | Expected empty response to cancelled request - "" should equal ""
25766 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
25767 INFO TEST-PASS | /tests/content/base/test/test_bug482935.html | Expected empty response to cancelled request - "" should equal ""
25768 INFO TEST-PASS | /tests/content/base/test/test_bug482935.html | Received cached value for second request - "1" should equal "1"
25769 INFO TEST-END | /tests/content/base/test/test_bug482935.html | finished in 2092ms
Comment 1 User image Mounir Lamouri (:mounir) 2011-04-08 11:50:21 PDT
Created attachment 524696 [details] [diff] [review]
Changes setTimeout to executeSoon [checked-in]

That might fix it. At least, it's not broken locally.
Comment 2 User image Mounir Lamouri (:mounir) 2011-04-11 17:07:51 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/6f1a2405f71e
Comment 3 User image Treeherder Robot 2011-04-11 19:39:43 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302574653.1302575554.24976.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/11 19:17:33

s: talos-r3-snow-004
25747 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 4 User image Treeherder Robot 2011-04-11 19:40:01 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302574653.1302575554.24976.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/11 19:17:33

s: talos-r3-snow-004
25747 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 5 User image Phil Ringnalda (:philor) 2011-04-11 19:40:26 PDT
The push right after that says "nope, not quite fixed."
Comment 6 User image :Ehsan Akhgari (in Taipei, laggy response time) 2011-04-11 19:41:19 PDT
Hmm, seems like this is now more flaky... :/
Comment 7 User image Mounir Lamouri (:mounir) 2011-04-11 22:50:56 PDT
Created attachment 525310 [details] [diff] [review]
Second attempt [checked-in]

This patch should be better.
Comment 8 User image Treeherder Robot 2011-04-12 12:32:24 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1302632426.1302633232.7942.gz
Rev3 WINNT 6.1 mozilla-aurora opt test mochitests-1/5 on 2011/04/12 11:20:26

s: talos-r3-w7-029
25771 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 9 User image Treeherder Robot 2011-04-12 12:36:32 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1302628702.1302629457.24052.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-aurora opt test mochitests-1/5 on 2011/04/12 10:18:22

s: talos-r3-snow-019
25760 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 10 User image :Ehsan Akhgari (in Taipei, laggy response time) 2011-04-12 15:50:25 PDT
Comment on attachment 525310 [details] [diff] [review]
Second attempt [checked-in]

Yeah, this does look better.  But it's best to pass the second parameter to setTimeout explicitly (0).  r=me with that fixed.
Comment 11 User image Mounir Lamouri (:mounir) 2011-04-12 17:53:59 PDT
Pushed the second attempt:
http://hg.mozilla.org/mozilla-central/rev/7a0810457ecd
Comment 12 User image Treeherder Robot 2011-04-13 07:24:05 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302701607.1302702765.31623.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/13 06:33:27

s: talos-r3-snow-048
25762 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 13 User image Treeherder Robot 2011-04-13 07:29:59 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1302703779.1302704530.8249.gz
Rev3 MacOSX Leopard 10.5.8 tracemonkey opt test mochitests-1/5 on 2011/04/13 07:09:39

s: talos-r3-leopard-025
25765 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 14 User image Treeherder Robot 2011-04-13 08:03:27 PDT
rcampbell%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1302703694.1302704614.8502.gz
Rev3 WINNT 5.1 devtools opt test mochitests-1/5 on 2011/04/13 07:08:14

s: talos-r3-xp-046
25771 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 15 User image Treeherder Robot 2011-04-13 08:07:40 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302704914.1302705935.15130.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/13 07:28:34

s: talos-r3-snow-033
25756 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 16 User image Mounir Lamouri (:mounir) 2011-04-13 10:21:50 PDT
I have no clue why this doesn't work. Bjarne and Jason, do you have an idea by any chance?
Comment 17 User image Treeherder Robot 2011-04-13 10:57:45 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1302715107.1302715970.28269.gz
Rev3 WINNT 6.1 cedar opt test mochitests-1/5 on 2011/04/13 10:18:27

s: talos-r3-w7-035
25755 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 18 User image Treeherder Robot 2011-04-13 20:23:48 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Services-Central/1302746220.1302747291.17579.gz
Rev3 MacOSX Snow Leopard 10.6.2 services-central opt test mochitests-1/5 on 2011/04/13 18:57:00

s: talos-r3-snow-035
25758 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 19 User image Treeherder Robot 2011-04-14 05:44:04 PDT
surkov.alexander%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302783147.1302783933.18312.gz
Rev3 Fedora 12 mozilla-central opt test mochitests-1/5 on 2011/04/14 05:12:27

s: talos-r3-fed-017
25038 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 20 User image Treeherder Robot 2011-04-14 06:09:36 PDT
Ms2ger%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302784347.1302785138.24030.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/14 05:32:27

s: talos-r3-snow-031
25779 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 21 User image Treeherder Robot 2011-04-14 06:11:32 PDT
mh+mozilla%glandium.org
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302784347.1302785138.24030.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/14 05:32:27

s: talos-r3-snow-031
25779 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 22 User image Bjarne (:bjarne) 2011-04-14 09:55:17 PDT
(In reply to comment #16)
> I have no clue why this doesn't work. Bjarne and Jason, do you have an idea by
> any chance?

Please see bug #482935, comment #69 and please also observe the time between landing bug #482935 (March 25th) and the first report of this failure (April 7th).
Comment 23 User image :Ehsan Akhgari (in Taipei, laggy response time) 2011-04-14 13:23:52 PDT
(In reply to comment #22)
> please also observe the time between
> landing bug #482935 (March 25th) and the first report of this failure (April
> 7th).

Do you have another changeset in mind which might have caused this failure?
Comment 24 User image :Ehsan Akhgari (in Taipei, laggy response time) 2011-04-14 20:57:47 PDT
*** Bug 650132 has been marked as a duplicate of this bug. ***
Comment 25 User image Treeherder Robot 2011-04-15 10:26:37 PDT
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302886662.1302887649.3912.gz
Rev3 WINNT 6.1 mozilla-central opt test mochitests-1/5 on 2011/04/15 09:57:42

s: talos-r3-w7-049
25764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 26 User image Treeherder Robot 2011-04-15 12:45:10 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302893848.1302894679.347.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitests-1/5 on 2011/04/15 11:57:28

s: talos-r3-leopard-024
25756 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 27 User image Treeherder Robot 2011-04-15 21:38:42 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302927251.1302928077.25957.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/15 21:14:11

s: talos-r3-snow-006
25754 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 28 User image Treeherder Robot 2011-04-16 10:14:30 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302972676.1302973509.29724.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/16 09:51:16

s: talos-r3-snow-023
25757 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 29 User image Treeherder Robot 2011-04-16 14:35:03 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1302988707.1302989504.25410.gz
Rev3 MacOSX Leopard 10.5.8 tracemonkey opt test mochitests-1/5 on 2011/04/16 14:18:27

s: talos-r3-leopard-019
25755 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 30 User image Treeherder Robot 2011-04-16 19:10:24 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303005219.1303006094.16905.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/16 18:53:39

s: talos-r3-snow-034
25746 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 31 User image Treeherder Robot 2011-04-16 21:04:05 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303011978.1303012885.7901.gz
Rev3 WINNT 6.1 mozilla-central opt test mochitests-1/5 on 2011/04/16 20:46:18

s: talos-r3-w7-020
25742 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 32 User image Treeherder Robot 2011-04-17 03:42:49 PDT
Ms2ger%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303035551.1303036442.26555.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/17 03:19:11

s: talos-r3-snow-005
25759 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 33 User image Treeherder Robot 2011-04-17 19:24:21 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303091365.1303092203.12414.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey opt test mochitests-1/5 on 2011/04/17 18:49:25

s: talos-r3-snow-052
25765 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 34 User image Treeherder Robot 2011-04-17 22:49:39 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303103183.1303104004.18967.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey opt test mochitests-1/5 on 2011/04/17 22:06:23

s: talos-r3-snow-049
25768 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 35 User image Treeherder Robot 2011-04-18 14:22:54 PDT
jorendorff
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303157235.1303160817.17170.gz
Rev3 WINNT 5.1 tracemonkey debug test mochitests-1/5 on 2011/04/18 13:07:15

s: talos-r3-xp-037
25774 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 36 User image Treeherder Robot 2011-04-18 16:58:13 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303169528.1303170316.31142.gz
Rev3 WINNT 6.1 mozilla-central opt test mochitests-1/5 on 2011/04/18 16:32:08

s: talos-r3-w7-027
25744 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 37 User image Treeherder Robot 2011-04-18 16:58:17 PDT
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303169528.1303170316.31142.gz
Rev3 WINNT 6.1 mozilla-central opt test mochitests-1/5 on 2011/04/18 16:32:08

s: talos-r3-w7-027
25744 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 38 User image Treeherder Robot 2011-04-18 19:11:11 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303170084.1303170889.970.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey opt test mochitests-1/5 on 2011/04/18 16:41:24

s: talos-r3-snow-028
25759 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 39 User image Treeherder Robot 2011-04-18 19:53:30 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303179229.1303179999.10474.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitests-1/5 on 2011/04/18 19:13:49

s: talos-r3-leopard-036
25770 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 40 User image Treeherder Robot 2011-04-18 21:33:25 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1302964873.1302965686.26244.gz
Rev3 MacOSX Snow Leopard 10.6.2 devtools opt test mochitests-1/5 on 2011/04/16 07:41:13

s: talos-r3-snow-026
25763 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 41 User image Treeherder Robot 2011-04-18 21:34:35 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1303049668.1303050412.8403.gz
Rev3 MacOSX Snow Leopard 10.6.2 devtools opt test mochitests-1/5 on 2011/04/17 07:14:28

s: talos-r3-snow-041
25778 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 42 User image Treeherder Robot 2011-04-18 21:35:18 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1303136301.1303137229.6452.gz
Rev3 MacOSX Snow Leopard 10.6.2 devtools opt test mochitests-1/5 on 2011/04/18 07:18:21

s: talos-r3-snow-054
25752 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 43 User image Treeherder Robot 2011-04-18 21:43:26 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1302880024.1302880792.800.gz
Rev3 WINNT 6.1 devtools opt test mochitests-1/5 on 2011/04/15 08:07:04

s: talos-r3-w7-022
25762 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 44 User image Treeherder Robot 2011-04-18 22:07:29 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303185406.1303188205.15738.gz
Rev3 WINNT 5.1 tracemonkey debug test mochitests-1/5 on 2011/04/18 20:56:46

s: talos-r3-xp-039
25774 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 45 User image Treeherder Robot 2011-04-18 23:21:46 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303192626.1303193440.5348.gz
Rev3 WINNT 6.1 tracemonkey opt test mochitests-1/5 on 2011/04/18 22:57:06

s: talos-r3-w7-015
25773 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 46 User image Treeherder Robot 2011-04-18 23:49:49 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303194581.1303195381.13315.gz
Rev3 WINNT 6.1 mozilla-central opt test mochitests-1/5 on 2011/04/18 23:29:41

s: talos-r3-w7-041
25755 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 47 User image Treeherder Robot 2011-04-19 00:15:38 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303195593.1303196575.18073.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey opt test mochitests-1/5 on 2011/04/18 23:46:33

s: talos-r3-snow-019
25751 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 48 User image Treeherder Robot 2011-04-19 07:28:16 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303222163.1303222972.27867.gz
Rev3 WINNT 6.1 tracemonkey opt test mochitests-1/5 on 2011/04/19 07:09:23

s: talos-r3-w7-025
25767 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 49 User image Treeherder Robot 2011-04-19 11:35:56 PDT
dtownsend%oxymoronical.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303237061.1303237873.7578.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/19 11:17:41

s: talos-r3-snow-048
25778 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 50 User image Treeherder Robot 2011-04-19 11:36:08 PDT
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303237061.1303237873.7578.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/19 11:17:41

s: talos-r3-snow-048
25778 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 51 User image Treeherder Robot 2011-04-19 12:03:22 PDT
dtownsend%oxymoronical.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303238745.1303239479.14147.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/19 11:45:45

s: talos-r3-snow-053
25758 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 52 User image Treeherder Robot 2011-04-19 12:09:55 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303238745.1303239479.14147.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/19 11:45:45

s: talos-r3-snow-053
25758 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 53 User image Treeherder Robot 2011-04-19 12:10:21 PDT
zackw%panix.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303238745.1303239479.14147.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/19 11:45:45

s: talos-r3-snow-053
25758 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 54 User image Treeherder Robot 2011-04-19 15:50:42 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303238745.1303239479.14147.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitests-1/5 on 2011/04/19 11:45:45

s: talos-r3-snow-053
25758 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 55 User image Bjarne (:bjarne) 2011-04-19 16:00:43 PDT
(In reply to comment #23)
> Do you have another changeset in mind which might have caused this failure?

Not really - I'm just pointing out the timespan and the fact that there was another unrelated issue (bug #552651 I believe) which caused this *test* to always leak independent of the code-change from bug #482935.

Btw, is it just me or has the frequency of this increased? (8 reports on April 19th vs 2 reports on April 12th)
Comment 56 User image Mounir Lamouri (:mounir) 2011-04-19 16:20:42 PDT
(In reply to comment #55)
> Btw, is it just me or has the frequency of this increased? (8 reports on April
> 19th vs 2 reports on April 12th)

My fault. While trying to fix it, I actually make it more orange. Though, I don't think we should backout unless my patches went in the wrong direction.
Bjarne, do you think you can find the time to investigate? To know if I should take some to do it.
Comment 57 User image Mounir Lamouri (:mounir) 2011-04-19 16:21:19 PDT
(In reply to comment #56)
> Bjarne, do you think you can find the time to investigate? To know if I should
> take some to do it.

And you seem to be the best person to look at that ;)
Comment 58 User image Treeherder Robot 2011-04-19 16:30:39 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303254086.1303254832.24135.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitests-1/5 on 2011/04/19 16:01:26

s: talos-r3-leopard-046
25764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 59 User image Treeherder Robot 2011-04-19 16:30:44 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303254086.1303254832.24135.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitests-1/5 on 2011/04/19 16:01:26

s: talos-r3-leopard-046
25764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 60 User image Bjarne (:bjarne) 2011-04-20 05:38:35 PDT
(In reply to comment #57)
> And you seem to be the best person to look at that ;)

Who said that flattery will get you nowhere..?  ;)  Try changing the two xhr2.open-calls to do async requests (i.e. remove last param). Since you've changed them to terminate on listeners anyway there's no reason to do those calls synchronously. I tried it locally and it works (but I'm not able to reproduce the error). I could submit a patch but this change is utterly trivial and you seem to have a shorter review-approval-checkin path than I do...

Why would this improve the situation? Well, I'm actually not 100% sure it will but it's worth a shot and it won't hurt. XHR spins the main-thread event-loop on sync-requests and that has never seemed to me like a very safe thing to do.
Comment 61 User image Mounir Lamouri (:mounir) 2011-04-20 05:48:37 PDT
(In reply to comment #60)
> (In reply to comment #57)
> > And you seem to be the best person to look at that ;)
> 
> Who said that flattery will get you nowhere..?  ;)  Try changing the two
> xhr2.open-calls to do async requests (i.e. remove last param). Since you've
> changed them to terminate on listeners anyway there's no reason to do those
> calls synchronously. I tried it locally and it works (but I'm not able to
> reproduce the error).

That was no flattery, you obviously know much more than I do about what the test is actually testing.

> I could submit a patch but this change is utterly trivial
> and you seem to have a shorter review-approval-checkin path than I do...

You just have to know the person to ask the review to ;). If you write a patch and ask a review to Ehsan, I can bet he will reply *very* quickly: he is very responsive for random oranges patches.

> Why would this improve the situation? Well, I'm actually not 100% sure it will
> but it's worth a shot and it won't hurt. XHR spins the main-thread event-loop
> on sync-requests and that has never seemed to me like a very safe thing to do.

The only thing I would not like to happen is to hide a real issue by writing a test that is going around it.
Comment 62 User image Bjarne (:bjarne) 2011-04-20 05:55:58 PDT
(In reply to comment #61)
> The only thing I would not like to happen is to hide a real issue by writing a
> test that is going around it.

It won't hide anything - it will indicate that spinning the event-loop causes issues.
Comment 63 User image Bjarne (:bjarne) 2011-04-20 05:58:08 PDT
Created attachment 527243 [details] [diff] [review]
Using asynchronous xhrs instead of synchronous
Comment 64 User image :Ehsan Akhgari (in Taipei, laggy response time) 2011-04-20 11:47:03 PDT
Comment on attachment 527243 [details] [diff] [review]
Using asynchronous xhrs instead of synchronous

Cool, let's try this!
Comment 65 User image Bjarne (:bjarne) 2011-04-20 12:36:23 PDT
Ok - requesting checkin...
Comment 66 User image Mounir Lamouri (:mounir) 2011-04-20 12:46:02 PDT
Fixed in cedar. Should be synced with mozilla-central in the next 24 hours.
Comment 67 User image Treeherder Robot 2011-04-20 16:22:22 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303338058.1303338844.20340.gz
Rev3 WINNT 6.1 mozilla-central opt test mochitests-1/5 on 2011/04/20 15:20:58

s: talos-r3-w7-030
25762 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 68 User image Treeherder Robot 2011-04-20 22:31:23 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303361430.1303362549.21177.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey opt test mochitests-1/5 on 2011/04/20 21:50:30

s: talos-r3-snow-043
25761 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 69 User image Mounir Lamouri (:mounir) 2011-04-21 01:16:06 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/4230d1472963

And thanks for the patch Bjarne :)
Comment 70 User image Treeherder Robot 2011-04-21 07:35:08 PDT
rcampbell%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1303320032.1303320803.319.gz
Rev3 MacOSX Snow Leopard 10.6.2 devtools opt test mochitests-1/5 on 2011/04/20 10:20:32

s: talos-r3-snow-036
25761 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 71 User image Treeherder Robot 2011-04-21 07:35:36 PDT
rcampbell%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1303320497.1303321408.3213.gz
Rev3 WINNT 6.1 devtools opt test mochitests-1/5 on 2011/04/20 10:28:17

s: talos-r3-w7-045
25759 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 72 User image Treeherder Robot 2011-04-22 08:38:55 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1303482655.1303483376.21738.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-aurora opt test mochitests-1/5 on 2011/04/22 07:30:55

s: talos-r3-snow-035
25760 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 73 User image Treeherder Robot 2011-04-26 11:34:37 PDT
cdleary%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1303830391.1303831394.19484.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey opt test mochitests-1/5 on 2011/04/26 08:06:31

s: talos-r3-snow-040
25775 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 74 User image :Ehsan Akhgari (in Taipei, laggy response time) 2011-04-26 14:48:23 PDT
Thank you all!  :-)
Comment 75 User image Treeherder Robot 2011-04-26 20:14:57 PDT
chris%pearce.org.nz
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1303871647.1303872696.24674.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-aurora opt test mochitests-1/5 on 2011/04/26 19:34:07

s: talos-r3-leopard-048
25771 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 76 User image Treeherder Robot 2011-05-03 11:11:54 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1304432206.1304433203.32639.gz
Rev3 WINNT 6.1 mozilla-aurora opt test mochitests-1/5 on 2011/05/03 07:16:46

s: talos-r3-w7-031
25764 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 77 User image Treeherder Robot 2011-05-05 00:31:55 PDT
rnewman%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1304576592.1304577590.28060.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-aurora opt test mochitests-1/5 on 2011/05/04 23:23:12

s: talos-r3-snow-016
25745 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 78 User image Treeherder Robot 2011-05-05 15:01:17 PDT
dbaron
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1304628528.1304629407.9384.gz
Rev3 WINNT 6.1 mozilla-aurora opt test mochitests-1/5 on 2011/05/05 13:48:48

s: talos-r3-w7-045
25768 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 79 User image Treeherder Robot 2011-05-06 21:58:48 PDT
bz%mit.edu
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1304741769.1304742880.24632.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-aurora opt test mochitests-1/5 on 2011/05/06 21:16:09

s: talos-r3-snow-029
25758 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 80 User image Treeherder Robot 2011-05-07 12:44:25 PDT
mfinkle%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1304780043.1304781006.27280.gz
Rev3 WINNT 5.1 mozilla-aurora opt test mochitests-1/5 on 2011/05/07 07:54:03

s: talos-r3-xp-015
25752 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 81 User image Treeherder Robot 2011-05-07 13:15:17 PDT
mfinkle%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1304778794.1304779743.20190.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-aurora opt test mochitests-1/5 on 2011/05/07 07:33:14

s: talos-r3-snow-009
25770 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 82 User image Treeherder Robot 2011-05-07 13:15:42 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1304778794.1304779743.20190.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-aurora opt test mochitests-1/5 on 2011/05/07 07:33:14

s: talos-r3-snow-009
25770 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 83 User image Treeherder Robot 2011-05-11 07:27:53 PDT
mbrubeck%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1305122514.1305123293.24455.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-aurora opt test mochitests-1/5 on 2011/05/11 07:01:54

s: talos-r3-snow-052
25770 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 84 User image Treeherder Robot 2011-05-11 13:46:13 PDT
mbrubeck%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1305140408.1305143288.8501.gz
Rev3 WINNT 6.1 mozilla-aurora opt test mochitests-1/5 on 2011/05/11 12:00:08

s: talos-r3-w7-008
25757 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 85 User image cmtalbert 2011-05-11 17:58:33 PDT
Test only change for a random orange.  Can we land it on aurora?
Comment 86 User image Treeherder Robot 2011-05-11 17:58:48 PDT
ctalbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1305160526.1305161254.4313.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-aurora opt test mochitests-1/5 on 2011/05/11 17:35:26

s: talos-r3-snow-006
25753 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug482935.html | Received fresh value for second request - got "1", expected "0"
Comment 87 User image JP Rosevear [:jpr] 2011-05-12 14:45:12 PDT
Please land for Aurora by Monday May 16 or the approval will potentially be lost.  Please mark as status-firefox5 fixed when you do.
Comment 88 User image Bjarne (:bjarne) 2011-05-13 03:43:08 PDT
I'm really not sure about the procedure to get this into aurora so I'll try first with good, old "checkin-needed" (assuming I'm supposed to drive this)...
Comment 89 User image Dão Gottwald [:dao] 2011-05-13 04:14:37 PDT
(In reply to comment #85)
> Test only change for a random orange.  Can we land it on aurora?

You can generally do this without approval.

Note You need to log in before you can comment on or make changes to this bug.