Last Comment Bug 648653 - Update version numbers everywhere to those specified in the process document
: Update version numbers everywhere to those specified in the process document
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: christian
:
Mentors:
http://mozilla.github.com/process-rel...
: 582672 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-08 14:53 PDT by christian
Modified: 2011-04-24 00:27 PDT (History)
20 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Version bump to 5.0a1 for mozilla-central (if done on Monday) (962 bytes, patch)
2011-04-08 15:24 PDT, christian
benjamin: review+
Details | Diff | Splinter Review
Version bump to 6.0a1 for mozilla-central (if done on Tuesday) (962 bytes, patch)
2011-04-08 15:25 PDT, christian
benjamin: review+
Details | Diff | Splinter Review
Version bump to 5.0a1 for mobile (835 bytes, patch)
2011-04-11 11:23 PDT, Matt Brubeck (:mbrubeck)
mark.finkle: review+
Details | Diff | Splinter Review
Version bump to 6.0a1 for mobile (835 bytes, patch)
2011-04-11 11:23 PDT, Matt Brubeck (:mbrubeck)
mark.finkle: review+
Details | Diff | Splinter Review

Description christian 2011-04-08 14:53:05 PDT
Update version numbers everywhere to those specified in the process document. I plan to do this early Monday, 2011-04-11.

mozilla-central
Firefox: 5.0a1
Gecko: 5.0a1

mozilla-aurora
Firefox: 5.0a2
Gecko: 5.0a2

mozilla-beta (doesn't need to be done right now but can't hurt)
Firefox: 5.0
Gecko: 5.0

See the doc @ http://mozilla.github.com/process-releases/draft/development_specifics/
Comment 1 christian 2011-04-08 15:12:55 PDT
There is some debate if we should just wait for the aurora merge and land 6.0a1 on mozilla-central instead. I'll get a patch for both cooked up while we discuss.
Comment 2 christian 2011-04-08 15:24:47 PDT
Created attachment 524763 [details] [diff] [review]
Version bump to 5.0a1 for mozilla-central (if done on Monday)
Comment 3 christian 2011-04-08 15:25:13 PDT
Created attachment 524764 [details] [diff] [review]
Version bump to 6.0a1 for mozilla-central (if done on Tuesday)
Comment 4 Benjamin Smedberg [:bsmedberg] 2011-04-08 15:32:21 PDT
apart from the policy decision, both patches are correct. Doing this on Monday will require more work in crash-stats and metrics, I think, for a single day of builds.
Comment 5 Matt Brubeck (:mbrubeck) 2011-04-11 11:23:20 PDT
Created attachment 525111 [details] [diff] [review]
Version bump to 5.0a1 for mobile
Comment 6 Matt Brubeck (:mbrubeck) 2011-04-11 11:23:43 PDT
Created attachment 525112 [details] [diff] [review]
Version bump to 6.0a1 for mobile
Comment 7 Matt Brubeck (:mbrubeck) 2011-04-11 11:24:22 PDT
Long-term, I think we should get rid of the separate mobile version number, but for now it will need to be updated too.
Comment 8 christian 2011-04-11 15:59:54 PDT
We're going with the bump to 6.0a1 tomorrow.
Comment 9 christian 2011-04-12 06:55:40 PDT
http://hg.mozilla.org/mozilla-central/rev/a95d42642281

Forgot to include the bug # in the commit, darn.
Comment 10 Robert Kaiser 2011-04-12 14:42:25 PDT
*** Bug 582672 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.