Test results for Download Statusbar on OS X are unrealistically low

RESOLVED WONTFIX

Status

Testing
Talos
RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: Wladimir Palant, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Talos tests show that Download Statusbar adds 80-100ms to the Firefox startup time on Windows and Linux. Yet on Mac OS X it is supposed to be only 10ms. This is both in the March 26th test run and April 2nd, for the latter the result was still a 10ms increase if you ignore the two outliers. This extension has no OS X specific code path or anything like that, it isn't a fluke either (same result in two test runs). However, this result cannot be correct, Download Statusbar is probably being tested in a non-functional state on OS X.
I think this is INVALID. My previous tests on Mac OS produced an overhead of around 4% (average 18ms delta, tested on beta 10), and I just performed the same tests and the result was around 6% (30ms average delta, tested on 4.0). I have confirmed the add-on was properly installed and it is fully functional.
(Reporter)

Comment 2

6 years ago
If that's INVALID then we have a Firefox bug on non-Mac operating systems. All the more reason to investigate what exactly is causing overhead on Windows/Linux and why the same overhead isn't present on OS X. As I said, this extension behaves exactly the same regardless of operating system. My own tests with Download Statusbar on Windows 7 confirmed that its measured Windows overhead is realistic. I got somewhat lower numbers but that's probably due to bug 647954 and bug 648732 (I had both fixed locally).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.