Closed Bug 648845 Opened 12 years ago Closed 12 years ago

Textbox content is not restored anymore in FF4

Categories

(Firefox :: Session Restore, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 624661

People

(Reporter: alessandroantonelli2, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

When restoring a session, Firefox 4 reloads textboxes content instead of restoring it. This causes users to lose changes made to textboxes. Note that in older Firefox version (i.e. 3.6, 3.5 and 3.0) textbox content was correctly restored.

For a Wikipedia editor like me is really frustrating to lose what I was writing after a browser crash. If this bug won't be fixed soon I'll have to switch back to FF 3.6 or to another browser.

Reproducible: Always

Steps to Reproduce:
1. Open a random Wikipedia article, and some other random tabs
2. Click on "edit" in the Wikipedia page
3. Select all the text in the textbox, delete it and write at its place "Lorem ipsum"
4. Restart Firefox and restore your last session
Actual Results:  
In the Wikipedia tab, the textbox shows the original text

Expected Results:  
In the Wikipedia tab, the textbox should show "Lorem ipsum".
Duplicate of bug 624661?
Sounds like it to me. Marking as such
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
> Duplicate of bug 624661?

You're right, thanks.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.