The default bug view has changed. See this FAQ.

Can't open new message window

RESOLVED FIXED in seamonkey2.6

Status

SeaMonkey
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Doug H, Assigned: Ian Neal)

Tracking

Trunk
seamonkey2.6
Other
Mac OS X

SeaMonkey Tracking Flags

(seamonkey2.6 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.18) Gecko/20110320 not Firefox/4.0 not Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.18) Gecko/20110320 not Firefox/4.0 not Firefox/4.0

When I have the mail window and browser window minimized (in the dock) and the seamonkey menu bar up I can't open a new message window unless i bring either the browser window or mail window up out of the dock. I go to file and there is no choice for new message.
Only new browser, tab or composer page. 

Reproducible: Always

Comment 1

6 years ago
This is also true on trunk. When all windows are minimized, I think we rely on the hiddenwindow.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
(Assignee)

Comment 2

6 years ago
Created attachment 555729 [details] [diff] [review]
Add mailNavigatorOverlay to hiddenWindow

This patch:
* Adds mailNavigatorOverlay.xul as an overlay to hiddenWindow.xul

Could you see if this works.
The other options would be to:
* move overlaying by mailNavigatorOverlay.xul from navigator.xul to navigatorOverlay.xul
* fold mailNavigatorOverlay into navigatorOverlay.xul
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #555729 - Flags: feedback?(stefanh)

Comment 3

6 years ago
Comment on attachment 555729 [details] [diff] [review]
Add mailNavigatorOverlay to hiddenWindow

It works, but we have a couple of issues:

1) "Send link" in the file menu is enabled (could be disabled in hiddenWindowStartup(), see navigator.js)
2) File --> New --> Contact opens partially off-screen because of bug 356742. If this window is opened from the hiddenWindow, I think we should exclude the modal feature (modal is what makes it a sheet). Last time I checked the function was shared with Thunderbird and the problem existed there too.
3) Then I did saw a js error complaining about no content, but now I fail to reproduce it (sorry).

Should we assume that mailNews is always included? And if we have decided that it's ok to merge browser and mailNews, maybe we should just merge mailNavigatorOverlay into navigatorOverlay (like you suggested as an alternative)?

Minusing for now, since I think we need to address the issues and settle browser/mail dependencies.
Attachment #555729 - Flags: feedback?(stefanh) → feedback-
(Assignee)

Comment 4

6 years ago
Created attachment 556274 [details] [diff] [review]
Add mailNavigatorOverlay to navigatorOverlay [Checked in: Comment 11]

Changes since last patch:
* move overlaying by mailNavigatorOverlay.xul from navigator.xul to navigatorOverlay.xul
* disable sendLink and sendPage (sendPage was not being disabled properly, because it was referenced as Browser:SendPage, since the original file when it was under mailnews/base/resources/content)

I would suggest that issue 2 is either dealt with using the workaround of removing modal or left until bug 356742 is fixed. I'll let Mnyromyr comment on that.
Attachment #555729 - Attachment is obsolete: true
Attachment #556274 - Flags: feedback?(mnyromyr)
(Assignee)

Updated

6 years ago
Blocks: 682579

Comment 5

6 years ago
Comment on attachment 556274 [details] [diff] [review]
Add mailNavigatorOverlay to navigatorOverlay [Checked in: Comment 11]

(In reply to Ian Neal from comment #4)
> I would suggest that issue 2 is either dealt with using the workaround of
> removing modal or left until bug 356742 is fixed.

It'd be better to fix bug 356742, if the misguided sheet wouldn't be visible. But a non-really-usable, non-movable, misplaced dialog is not tolerable, so a workaround would be good.

(In reply to Stefan [:stefanh] (away until September 24) from comment #3)
> 2) File --> New --> Contact opens partially off-screen because of bug
> 356742. If this window is opened from the hiddenWindow, I think we should
> exclude the modal feature (modal is what makes it a sheet).

Are you sure that "modal" is the key problem here?

Funny thing is that I had the very similar problem last week with Mnenhy on Mac: On startup of the Mnenhy js module, my beta versions open a modal,centerscreen dialog with some info. This dialog opened centered upon the upper left corner of the screen, because it gets opened before any real windows. 

The workaround was killing the centerscreen flag if the window we're calling the openDialog on (http://mxr.mozilla.org/comm-central/source/suite/mailnews/mailOverlay.js#39) has zero width.
Attachment #556274 - Flags: feedback?(mnyromyr) → feedback+

Comment 6

6 years ago
See also <http://mxr.mozilla.org/comm-central/source/mozilla/xpfe/appshell/src/nsAppShellService.cpp?mark=378-381#366> (including Mac specific code parts before).
(Assignee)

Updated

6 years ago
Attachment #556274 - Flags: review?(mnyromyr)

Comment 7

6 years ago
Comment on attachment 556274 [details] [diff] [review]
Add mailNavigatorOverlay to navigatorOverlay [Checked in: Comment 11]

Fine by me, but I'd like Neil's architectural eye on that as well. ;-)
Attachment #556274 - Flags: superreview?(neil)
Attachment #556274 - Flags: review?(mnyromyr)
Attachment #556274 - Flags: review+

Comment 8

6 years ago
Interesting... bug 144828 moved mailNavigatorOverlay.xul to navigator, and stopped it depending on mail (without mail, or if external mailto is manually set, then it uses external mailto.) Then there's bug 108745 which moved out out of navigatorOverlay and into navigator...

Comment 9

6 years ago
Well, at least we don't have to worry about overlaying view source any more.
Comment on attachment 556274 [details] [diff] [review]
Add mailNavigatorOverlay to navigatorOverlay [Checked in: Comment 11]

Opening the hidden window menus results in a boatload of errors :-(

Fortunately, this patch doesn't add any new ones :-)
Attachment #556274 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 11

6 years ago
Comment on attachment 556274 [details] [diff] [review]
Add mailNavigatorOverlay to navigatorOverlay [Checked in: Comment 11]

http://hg.mozilla.org/comm-central/rev/efed0a9a84bd
Attachment #556274 - Attachment description: Add mailNavigatorOverlay to navigatorOverlay → Add mailNavigatorOverlay to navigatorOverlay [Checked in: Comment 11]
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
status-seamonkey2.6: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.6
You need to log in before you can comment on or make changes to this bug.