Closed Bug 64887 Opened 22 years ago Closed 22 years ago

Built-in "Download Manager" Needed within Mozilla

Categories

(SeaMonkey :: UI Design, defect)

x86
Windows NT
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 25995

People

(Reporter: Peter, Assigned: vishy)

Details

(Keywords: helpwanted)

Built-in "Download Manager" Needed within Mozilla.

Mozilla should have a built-in "Download Manager" like GetRight or Gozilla. It
would be the first browser to have this valuable and popular feature integrated
into the browser. This is something that is sorely missing from all current
large browsers.

The features of this Download Manager should include:

1. Resumable downloads (this is a biggie) - see bug 18004

2. Automatically find and add alternate URL's

3. Segmented Downloads (multiple parts of same file at once from one or more
URL's) - I can file a separate bug for this, if required.

4. Preferences Settings for default or last used download directory. - see bug 7840

5. The DM could be a MySidebar app. (or as a minimum, multiple downloads would
appear in only ONE download window - see bug 25995)

*** This bug has been marked as a duplicate of 25995 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
No, this is not a duplicate.

The other bug is specifically focused on having one download window for multiple
downloads. It merely has the words "download manager" mentioned in the summary,
but it is not an INTERNAL Download Manger request.

This bug requests a "complete module" that includes ALL features of a
full-featured download manager, including but not limited to having one window
for multiple downloads.
Peter, add your suggestions to *existing* bugs. You keeps claiming in a lot of
your bugs that they're not duplicates because the dupe doesn't include
enhancement request x.

Please use existing bugs. Verifying duplicate.
Status: RESOLVED → VERIFIED
i'm must admit i am unclear when a bug is a duplicate and when not. The
impression i have so far is that bugs should be as detailed as possible.
Frequently, i have requested additional features in a bug only to be told to
file a separate report. the other bugs i listed above only deal with specific
and individual aspects of a download manager. There is no bug i could find that
UNIFIED all these various bugs into one request for the feature: Download
Manager. My intention is to make sure that all the various bugs don't get solved
in "incompatible" or disparate ways. It would be much nicer if these features
were somehow "integrated".

If i am understanding something wrong here, please let me know. Thank You.
Just for clarification, its best mention feature request in the origial bug, if
the person dealing with the bug sees the feature as something that can go with
their work, they will include it, often they will decide to bother with your
feature request seperatly once the first bug is fixed, asking you to file it
seperatly, possible including a dependence tree. For this example, you would
probably want to just mention the features you don't see listed in the other bug
that you wish for in this. But it'll probably be best to wait till the other bug
has some code landed, so you can see where they are going with it.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.