The default bug view has changed. See this FAQ.

crash [@ nsIContent::Tag()]

VERIFIED FIXED in mozilla6

Status

()

Core
Disability Access APIs
--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: MarcoZ, Assigned: tbsaunde)

Tracking

({crash, topcrash})

Trunk
mozilla6
x86
Windows NT
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [aurora-backout], crash signature)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-733858f4-ab1e-42c9-bbe0-03a962110411 .
============================================================= 

The call is made from nsHypertExtAccessible::nativeState
(Reporter)

Updated

6 years ago
Component: Disability Access → Disability Access APIs
Product: Firefox → Core
QA Contact: disability.access → accessibility-apis

Comment 1

6 years ago
Trevor, you're call I think, looks as regression from your state patch.
(Reporter)

Updated

6 years ago
Blocks: 634218
Keywords: topcrash
Trevor, can you drop your try build link here when it is ready?
Assignee: nobody → trev.saunders
(Assignee)

Comment 3

6 years ago
http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/trev.saunders@gmail.com-48e8c874a008/tryserver-win32/firefox-4.2a1pre.en-US.win32.zip

This build adds the IsDefunct check discussed on IRC.  Would  someone with a windows machine mind testing?  Sorry about the delay tryserver took forever :(

Comment 4

6 years ago
bug 648989 has same problem (might need different patch though but it's unlikely).
(Assignee)

Comment 5

6 years ago
Created attachment 525271 [details] [diff] [review]
bug 648988 crash @ nsIContent::Tag()
(Assignee)

Updated

6 years ago
Attachment #525271 - Flags: review?(surkov.alexander)

Comment 6

6 years ago
Comment on attachment 525271 [details] [diff] [review]
bug 648988 crash @ nsIContent::Tag()


> PRUint64
> nsAccessible::State()
> {
>+  if (IsDefunct())
>+    return states::DEFUNCT;
>+
>   PRUint64 state = NativeState();
>   if (state & states::DEFUNCT)
>     return state;

no need to check it

> PRUint64
> nsApplicationAccessible::NativeState()
> {
>-  return IsDefunct() ? states::DEFUNCT : 0;
>+  return 0;

then you should fix nsApplicationAccessible::State()
Attachment #525271 - Flags: review?(surkov.alexander) → review+
(Assignee)

Comment 7

6 years ago
Created attachment 525279 [details] [diff] [review]
patch to land
(Assignee)

Comment 8

6 years ago
Created attachment 525284 [details] [diff] [review]
patch to land

correctly fix nsApplicationAccessible::State()
Attachment #525271 - Attachment is obsolete: true
Attachment #525279 - Attachment is obsolete: true
(Reporter)

Comment 9

6 years ago
I can still reproduce the crashes with the try-server build. It also doesn't fix bug 648989.
(Reporter)

Comment 10

6 years ago
Forget that last comment, after talking to Trevor on IRC, it iis apparrent the try-server build I was testing was bad, and the patch on this bug is actually good to go.
http://hg.mozilla.org/mozilla-central/rev/15dc9bbc94d6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.2
(Reporter)

Comment 12

6 years ago
The try-server build here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/surkov.alexander@gmail.com-4546f104f670/tryserver-win32/
fixes this bug. So the patch that landed seems to be good. Will confirm with nightly build as soon as it's ready.
(Reporter)

Comment 13

6 years ago
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0a2) Gecko/20110412 Firefox/5.0a2
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

6 years ago
Backed out of Aurora in the wake of the bug 634218 backout:
http://hg.mozilla.org/mozilla-aurora/rev/bcc0d10b5d4b
Whiteboard: [aurora-backout]
Target Milestone: mozilla5 → mozilla6
(Reporter)

Comment 15

6 years ago
Sorry for the spam, the correct link of the backout changeset on Aurora is:
http://hg.mozilla.org/mozilla-aurora/rev/25feb8bd6294
Crash Signature: [@ nsIContent::Tag()]
You need to log in before you can comment on or make changes to this bug.