TI: Assertion failure: v.isBoolean(), at jsinterp.cpp:1320

RESOLVED DUPLICATE of bug 648999

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 648999
7 years ago
5 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The following testcase asserts on TI revision 74a8fb1bbec5 (run with -m -n -a),
tested on 64 bit:

function reportCompare(expected, actual, description) {
    typeof actual
}
function enterFunc(funcName) {
    try {
        reportCompare(expectCompile, actualCompile, ': compile actual');
    } catch (ex) {}
}
if (1) function test(f) {
    enterFunc();
    reportCompare(1, f(), "Both functions were defined.");
}
test();
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648999
(Reporter)

Updated

6 years ago
Blocks: 676763
(Reporter)

Comment 2

5 years ago
A testcase for this bug was already added in the original bug (bug 648999).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.