Firefox sync preferences lost if saved password data/history is cleared

RESOLVED DUPLICATE of bug 553400

Status

Cloud Services
Firefox Sync: UI
--
minor
RESOLVED DUPLICATE of bug 553400
7 years ago
7 years ago

People

(Reporter: gene.730+bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

Just noticed that if I use permanent private browsing mode, or if I use custom settings for history that include Clear History when Firefox Closes > Data: Saved Passwords, this also clears any pre-configured sync settings in Options > Sync.

Always able to replicate

Reproducible: Always

Steps to Reproduce:
1. Firefox 4 > Options > Sync > Complete a sync relationship/configuration (right up to the point where the URL loads to notes that sync is now configured)
2. Firefox 4 > Options > Privacy > Tick "Permanent private browsing" or use custom settings for history that includes Clear History when Firefox Closes > Data: Saved Passwords
3. Exit Firefox completely (Firefox > Exit)
4. Start Firefox
Actual Results:  
Now Options > Sync is "unconfigured" - any subsequent changes will not sync. Choosing Firefox > Synchronise now results in a prompt to setup sync. 

Expected Results:  
Clearing saved passwords for websites does not affect sync settings/sync credentials

Workaround is to *not* tick Clear History when Firefox Closes > Data: Saved Passwords. This is required even if Security > Remember passwords for sites is unticked
(Reporter)

Comment 1

7 years ago
Or to rephrase - to me the "Clear History when Firefox Closes > Data: Saved
Passwords" area means "Saved passwords for websites". I don't expect it to mean sync settings/credentials.
Component: Private Browsing → Firefox Sync: UI
Product: Firefox → Mozilla Services
QA Contact: private.browsing → sync-ui
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553400
You need to log in before you can comment on or make changes to this bug.