Last Comment Bug 649170 - Crashes every time i print html pages & am a frequent user of these 'on line' sites. [@ nsPIDOMWindow::GetFrameElementInternal()]
: Crashes every time i print html pages & am a frequent user of these 'on line'...
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 Windows XP
: -- critical with 1 vote (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
: Andrew Overholt [:overholt]
Mentors:
http://ancestry.com.au & http:/centre...
: 616279 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-11 16:14 PDT by Enid Bock
Modified: 2011-06-09 14:58 PDT (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (11.66 KB, patch)
2011-05-06 08:56 PDT, Olli Pettay [:smaug]
roc: review+
Details | Diff | Splinter Review

Description Enid Bock 2011-04-11 16:14:50 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 ( .NET CLR 3.5.30729)
Build Identifier: 

Crashes occur every time I print html pages within ancestry & centrelink -immediately shuts down Firefox without option to log out.

Reproducible: Always

Steps to Reproduce:
1. Sign in & open census record in ancestry.
2. View printer friendly option
3. Select print option
Actual Results:  
All of the above plus immediate crash.

Expected Results:  
Same

At the very least NOT CRASHED & allowed me to log out properly.
Comment 1 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-04-11 19:48:09 PDT
Hi Enid,
If you enter about:crashes in the url bar, do you see a list of crashes?  Could you copy those links to this bug?
Comment 2 Enid Bock 2011-04-11 21:12:23 PDT
Submitted Crash Reports


  

    
      
        Report ID
        	Date Submitted
      

    
    
    7e2d7cae-a1aa-47e8-ac85-65db9d7fe781	9/04/2011	3:27 PM
4b8a04fd-3076-427d-8a4d-405a78f7ec82	14/03/2011	7:33 PM
47bf0402-0e2e-484e-9dce-6b5bbf01fd01	25/02/2011	9:38 AM
c25b27c9-4eab-4af3-81cb-f3d27c4b3d59	4/02/2011	6:49 PM
bp-5e9ea1ec-fcb8-4bcc-ac2a-aa9112110129	30/01/2011	11:25 AM
bp-31a91fb2-839f-4efa-9264-6423a2110129	30/01/2011	10:53 AM
63869ede-b59a-489a-bc61-0bb59547abc9	17/12/2010	10:59 AM
89b8a582-e893-4796-92e2-7abdf5cc9eb8	12/11/2010	12:55 PM
cd1beb19-0d18-47b2-9df4-cf0e1948524f	12/11/2010	9:48 AM
a2bd632b-4a0b-4401-91a6-58afec1c7cc4	12/11/2010	9:47 AM
58999c5b-9d15-436b-950e-0cf90a24fdfb	12/11/2010	9:44 AM
d21d9ee3-5e06-4158-b164-9c998de22e2e	12/11/2010	9:43 AM
ec169f98-d011-4d67-847b-b8d04e16aac2	12/11/2010	9:42 AM
fa8688bb-0055-4614-b707-c0ee447723c0	22/10/2010	1:01 PM
5ac6af69-230e-497d-9347-ee5a92c3b618	12/10/2010	4:51 PM
7d52609f-2ea8-4327-8de1-cc22b5f09224	11/10/2010	5:01 PM
92291bae-0d77-4118-9047-b87b34d58022	11/10/2010	4:22 PM
6b204dbf-1c18-4890-bce9-b033c4b45945	11/10/2010	4:22 PM
a6078a6f-d27a-443f-87a6-9acb7770a368	11/10/2010	4:22 PM
b4243b59-dbfe-4268-a525-c1299809ad82	11/10/2010	11:17 AM
001576c6-17ee-4ae6-939b-2656382ac094	11/10/2010	10:21 AM
9e889029-0e70-4782-a185-82b614ecf284	29/09/2010	12:09 PM
1f8c2346-c05d-4368-b3fd-5ff8a63741a5	29/09/2010	11:10 AM
622270d8-0f7d-45b9-ac6b-f5acd7ad12db	7/09/2010	1:32 PM
17a0f840-74a8-4159-b29e-932a6bb974e4	3/09/2010	1:24 PM
16441452-b8c2-405d-a133-2d2512f627a1	31/08/2010	7:11 AM
bp-722244f8-878e-4db9-86a6-7a3422100826	26/08/2010	6:14 PM
29ea7da7-18d8-4e4f-9540-a2b112106b9a	22/08/2010	3:33 PM
7086ac62-9ebc-4305-9d55-fcf0afb7eafd	22/08/2010	7:50 AM
97b14c1a-d799-4ee1-bd38-b879b9c95df3	22/08/2010	7:49 AM
2199b5d4-f110-4603-93b8-df73aa9df314	22/08/2010	7:48 AM
66fb0ba4-38c3-4915-82eb-9d6e169248b8	21/08/2010	7:52 AM
8da37545-cc3e-4ceb-b173-e38d3e136abd	20/08/2010	6:32 PM
bp-18f61b24-4ff1-43e0-aef0-078842100819	20/08/2010	4:04 PM
f3f5941d-e827-4895-a56a-a68967d09bc2	13/08/2010	4:19 PM
bp-adabde54-a72b-4f85-8fa6-159332100812	12/08/2010	6:22 PM
b4fe0d37-f0d7-4b34-aede-25860e1f2285	10/08/2010	7:10 AM
ea19b034-ac09-46d0-96a1-7129155dada0	1/08/2010	2:56 PM
7fa03d5a-256c-4cbb-9aa9-66f671558ea6	31/07/2010	4:55 PM
f429d0a4-54a6-40ac-b268-44411b902108	31/07/2010	4:51 PM
6278bca5-9ef1-4f26-a1b0-3f1ff77a69a4	31/07/2010	8:41 AM
ab43ed0b-0110-4fa3-9727-1d8f629c0e25	21/07/2010	3:02 PM
e83224ad-47b3-4063-b5ff-983b81c51d20	20/07/2010	6:28 PM
bp-27af4891-335b-4702-b166-976f22100717	18/07/2010	2:09 PM
ee4d94f6-71d5-4168-9707-167e129efb5a	16/07/2010	1:59 PM
f49ffaad-1391-4eb9-ad47-5abf2175666c	10/07/2010	9:26 AM
025767e5-9e9d-40f0-bdfd-da5b26bd3693	9/07/2010	7:37 PM
b4d031fb-fc1b-481c-ab7e-94bfdb3b9a12	9/07/2010	7:10 PM
d036a257-9e3c-48d1-8e0b-d77e310c91cc	9/07/2010	5:27 PM
84cb427a-242e-4518-aed8-b45711773a32	5/07/2010	6:58 PM
5e039df9-30f4-448a-a02a-7a47e896ddf0	30/06/2010	9:57 AM
c964919a-056e-4fcb-a949-45c307e8c555	28/06/2010	8:45 PM
0a0bf5c0-80cb-4707-98cb-9d76e2bf3f30	25/06/2010	8:33 AM
11a3055c-1b81-4654-a7b9-0cd3f97f7024	25/06/2010	8:31 AM
bp-39fde20c-9304-4f36-baff-f4e5f2100602	3/06/2010	2:35 PM
bp-99278e97-ad53-4725-8b3f-b54082100602	2/06/2010	6:33 PM
bp-f3d54285-4d5e-4e44-a9bd-d52362100524	25/05/2010	9:11 AM
bp-48cbcf2e-6328-45f8-bd3a-fcc322100510	11/05/2010	8:04 AM
bp-e6786b07-b7c9-4b0d-8acc-049772100427	27/04/2010	5:08 PM
bp-e3064425-3cd3-4493-bd58-ac1022100427	27/04/2010	5:07 PM
bp-839c9153-2695-44d6-81fb-fb3cb2100424	25/04/2010	9:42 AM
bp-eab8914d-76a8-4a67-84d6-ef09f2100424	25/04/2010	9:10 AM
bp-f9fb766c-1258-43df-91b0-538232100410	10/04/2010	5:49 PM
bp-84f332fc-85a1-4a3c-92ce-050432100408	9/04/2010	8:30 AM
bp-ff7d675f-12a1-4183-9b48-3cfd22100407	8/04/2010	8:13 AM
bp-4bf725a3-7cfe-4525-878d-3bac62100401	2/04/2010	6:46 AM
bp-4c6f598e-ed98-4249-879e-8accd2100331	1/04/2010	4:52 PM
bp-d5356283-d299-42a4-9bf3-2b3a32100317	18/03/2010	7:46 AM
bp-3b237825-40c8-4a25-b9aa-98fdd2100302	3/03/2010	4:46 PM
bp-44926ead-8b03-4294-b6b3-07e682100225	26/02/2010	10:17 AM
bp-3c2323cb-0147-4a76-b6ad-ed73a2100225	25/02/2010	6:15 PM
bp-20b1c53b-2663-4988-9f0e-b109f2100206	7/02/2010	10:17 AM
bp-1c682715-4981-45cd-a0ff-dc8722100131	31/01/2010	7:26 PM
bp-09013a63-8f5f-4f07-becd-1ae302100128	28/01/2010	9:53 PM
bp-b454f937-af3f-43b3-b382-7bc9e2100114	14/01/2010	6:45 PM
bp-a6c4b40b-8d55-4f44-a548-38ec12100113	14/01/2010	5:52 PM
Comment 3 timeless 2011-04-12 00:44:15 PDT
So, your crashes date way too far back, and not all crashes are the same

FWIW, I'm using http://konigsberg.mozilla.org/crash-stats.html to review your crashes...

This is related to /some/ plugin:
Signature	nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) | xul.dll@0xa1ec3f
UUID	722244f8-878e-4db9-86a6-7a3422100826
Time 	2010-08-26 01:13:54.72243
Uptime	34442
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x1
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsCOMPtr_base::assign_from_qi 	obj-firefox/xpcom/build/nsCOMPtr.cpp:96
1 	xul.dll 	xul.dll@0xa1ec3f 	
2 	xul.dll 	nsNPAPIPluginInstance::GetDOMElement 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:1990
3 	xul.dll 	nsJSNPRuntime::OnPluginDestroy 	modules/plugin/base/src/nsJSNPRuntime.cpp:2039
4 	xul.dll 	nsNPAPIPluginInstance::Stop 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:1191

Flash:
Firefox 3.6.8 Crash Report [@ F_1339296399_____________________________ ]
ID: 18f61b24-4ff1-43e0-aef0-078842100819

Acrobat:
Firefox 3.6.8 Crash Report [@ AcroRd32.dll@0x34c945 ]
ID: adabde54-a72b-4f85-8fa6-159332100812

Most of the rest expired.

Your most common crash is this:
Signature	nsPIDOMWindow::GetFrameElementInternal()
UUID	5e9ea1ec-fcb8-4bcc-ac2a-aa9112110129
Time 	2011-01-29 17:25:02.557449
Uptime	1874
Last Crash	1893 seconds (31.6 minutes) before submission
Install Age	4370149 seconds (7.2 weeks) since version was first installed.
Product	Firefox
Version	3.6.13
Build ID	20101203075014
Branch	1.9.2
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 13 stepping 8
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x2c

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsPIDOMWindow::GetFrameElementInternal 	dom/base/nsPIDOMWindow.h:163
1 	xul.dll 	nsPrintEngine::InstallPrintPreviewListener 	layout/printing/nsPrintEngine.cpp:372
2 	xul.dll 	nsPrintEngine::FinishPrintPreview 	layout/printing/nsPrintEngine.cpp:3183
3 	xul.dll 	DocumentViewerImpl::Destroy 	
4 	xul.dll 	nsPagePrintTimer::~nsPagePrintTimer 	layout/printing/nsPagePrintTimer.cpp:60
5 	xul.dll 	nsPagePrintTimer::`scalar deleting destructor' 	
6 	xul.dll 	nsPagePrintTimer::Release 	layout/printing/nsPagePrintTimer.cpp:43
7 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:455
8 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:519
9 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
10 	xul.dll 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:250
11 	xul.dll 	nsThread::Shutdown 	xpcom/threads/nsThread.cpp:468
12 	xul.dll 	nsUrlClassifierDBService::Shutdown 	toolkit/components/url-classifier/src/nsUrlClassifierDBService.cpp:4288
13 	xul.dll 	nsUrlClassifierDBService::Observe 	toolkit/components/url-classifier/src/nsUrlClassifierDBService.cpp:4244
14 	xul.dll 	nsObserverService::NotifyObservers 	xpcom/ds/nsObserverService.cpp:182
15 	xul.dll 	xul.dll@0x9793cb 	
16 	xul.dll 	nsXREDirProvider::DoShutdown 	toolkit/xre/nsXREDirProvider.cpp:876
17 	xul.dll 	ScopedXPCOMStartup::~ScopedXPCOMStartup 	toolkit/xre/nsAppRunner.cpp:1048
18 	nspr4.dll 	nspr4.dll@0xd94f 	
19 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3528
Comment 4 Olli Pettay [:smaug] 2011-04-12 08:35:53 PDT
Enid, have you tried if Firefox 4 has the same problem?
(You seem to be using Firefox 3.6)
Comment 5 Enid Bock 2011-04-12 21:26:21 PDT
Thanks for all the advice, particularly re FF4 (which I had thought I'd installed - it was still sitting in my downloads).  Anyway have installed FF4, installed the latest driver update on my Epson printer and checked the plug ins which recommended updating adobe which I have.  Since then, I have had 6 successful prints direct from ancestry so I hope that the problem has been resolved.

Just as a side note, I've been submitting crash reports for the past couple of years wrt ancestry & mozilla & crashes.  Do these reports ever see the light of day?

Once again, thank you all 
PS(my son first recommended Mozilla to me after lots of probs with I.E. and I'd recommend it to anyone)
Comment 6 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-04-12 21:42:53 PDT
Yes, crash reports are aggregated on https://crash-stats.mozilla.com/ and there are a team of people that regularly file bugs about new crashes that appear there.
Comment 7 [Baboo] 2011-05-01 17:53:40 PDT
Does bp-7fb0745b-eeb8-4e2c-8fde-afd282110501 fit into this?
Comment 8 Olli Pettay [:smaug] 2011-05-02 03:21:12 PDT
yes! that is a very useful crash report.
Comment 9 Olli Pettay [:smaug] 2011-05-06 08:20:48 PDT
*** Bug 616279 has been marked as a duplicate of this bug. ***
Comment 10 Olli Pettay [:smaug] 2011-05-06 08:56:28 PDT
Created attachment 530643 [details] [diff] [review]
patch

I hope this helps.
Comment 11 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-09 02:11:23 PDT
Olli, can you explain what you think is going on here?
Comment 12 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-09 15:41:57 PDT
Comment on attachment 530643 [details] [diff] [review]
patch

Review of attachment 530643 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 13 Olli Pettay [:smaug] 2011-05-10 06:02:09 PDT
http://hg.mozilla.org/mozilla-central/rev/aac394a1bd91

Anyone who can reproduce this on trunk, could you please try the
next nightly build http://nightly.mozilla.org/
Comment 14 Olli Pettay [:smaug] 2011-05-17 01:33:12 PDT
I'm marking this fixed but please reopen if you see this crash on
Fx6.

Note You need to log in before you can comment on or make changes to this bug.