Last Comment Bug 649198 - Switch to Aurora branding by default in the mozilla-aurora repository
: Switch to Aurora branding by default in the mozilla-aurora repository
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 648368
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-11 17:42 PDT by christian
Modified: 2011-04-29 13:26 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Default to the aurora branding in the aurora repo (mozilla-aurora only) (574 bytes, patch)
2011-04-11 17:46 PDT, christian
gavin.sharp: review+
Details | Diff | Splinter Review

Description christian 2011-04-11 17:42:21 PDT
Switch to Aurora branding by default in the mozilla-aurora repository
Comment 1 christian 2011-04-11 17:46:11 PDT
Created attachment 525246 [details] [diff] [review]
Default to the aurora branding in the aurora repo (mozilla-aurora only)
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-04-12 05:43:11 PDT
Is the intention that we'll land this on Aurora every time we pull from m-c? catlee was talking about this yesterday and was wondering if we could do this without that manual step. I suppose the tradeoff is between "land a patch on every m-c->m-a pull" and "have something in aurora mozconfigs to switch branding".
Comment 3 christian 2011-04-12 06:41:02 PDT
No, we'll likely use configs. Gavan and I discussed that this was the best way for this merge.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-04-29 06:45:54 PDT
I assume we could use --with-branding=/browser/branding/aurora  in the mozconfig
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-04-29 12:11:42 PDT
Yes, but I prefer the confvar.sh change, since it associates the branding change with the repository, rather than only our build slaves.
Comment 7 Benjamin Smedberg [:bsmedberg] 2011-04-29 13:12:26 PDT
Hrm, that's going to require manual intervention at each m-c->aurora merge, no? I really think this ought to be a property of the build config, not the code itself. But I guess we'll see how much pain this causes.
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-04-29 13:21:16 PDT
Yes. I'm hoping it's not a lot of pain (particularly compared to the other merging work that will be necessary).
Comment 9 Chris AtLee [:catlee] 2011-04-29 13:26:25 PDT
We can set it in the mozconfig that's used for mozilla-aurora.

Note You need to log in before you can comment on or make changes to this bug.