the above URL crashes firefox - all the time

VERIFIED DUPLICATE of bug 644012

Status

()

VERIFIED DUPLICATE of bug 644012
7 years ago
7 years ago

People

(Reporter: rob.smeets, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

content when opened from IE (page also worked fine in 3.x):

<html>
<head>
<title>Web Authentication</title>
<meta http-equiv="Cache-control" content="no-cache">
<meta http-equiv="Pragma" content="no-cache">
<meta http-equiv="Expires" content="-1">
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style>
<!--
DIV.sidebar {
    RIGHT: 0px;
    POSITION: absolute;
    TOP: -1px;
    HEIGHT: 100%;
    width: 200;
}
DIV.graybar {
    RIGHT: 0px; POSITION: absolute; TOP: 0px; HEIGHT: 100%; BACKGROUND-COLOR: #f8f8f8
}
/* background not be shown for NEC */

DIV.header {
    BACKGROUND-POSITION: right 50%; LEFT: 0px; BACKGROUND-IMAGE:  url(images/background_web41.jpg); WIDTH: 100%; BACKGROUND-REPEAT: repeat; POSITION: absolute; TOP: 0px; HEIGHT: 52px; BACKGROUND-COLOR: #FFFFFF}


DIV.content {
    LEFT: 14px; MARGIN: 15px; POSITION: absolute; TOP: 60px
}
H1 {
    FONT-WEIGHT: bold; FONT-SIZE: 19px; MARGIN: 16px 0px 0px 25px; COLOR: #ffffff; FONT-FAMILY: Tahoma, Arial, Helvetica, sans-serif
}
H2 {
    FONT-WEIGHT: bold; FONT-SIZE: 15px; MARGIN: 10px 0px 0px 10px; COLOR: #336666; FONT-FAMILY: Arial, Helvetica, sans-serif
}
INPUT {
    FONT-SIZE: 12px; FONT-FAMILY: Arial, Helvetica, sans-serif
}
INPUT.button {
    MARGIN-TOP: 10px; FONT-WEIGHT: bold; WIDTH: 80px; COLOR: #ffffff; BACKGROUND-COLOR: #669999
}
P {
    FONT-SIZE: 12px; MARGIN: 0px 0px 10px; COLOR: #001133; FONT-FAMILY: Arial, Helvetica, sans-serif
}
TD {
    FONT-WEIGHT: bold; FONT-SIZE: 12px; COLOR: #336666; FONT-FAMILY: Arial, Helvetica, sans-serif
}
TD.message {
    FONT-WEIGHT: normal; COLOR: #000000
}
-->
</STYLE>
<script language="javascript" src="./loginscript.js"></script>
<script>
    var url = "";
    if(url != ""){
        var link = document.location.href;
        var searchString = "?redirect=";
        var equalIndex = link.indexOf(searchString);
        var redirectUrl = "";
        if(equalIndex > 0) {
                equalIndex += searchString.length;
                redirectUrl += link.substring(equalIndex);
                //attach the redirect url only if the ext web auth url doesn't contain it
                searchString = "&redirect=";
                equalIndex = url.indexOf(searchString);
                if(equalIndex < 0){
                    url+= "&redirect=";
                    url+=redirectUrl;
                }
        }
        window.location.href = url;
    }

function getErrorMsgIfAny(){
 if(document.forms[0].err_flag.value == 1){
    document.writeln(' \
     <tr align="center"> <td colspan="2" style="color:#CC0000">Login Error.</td>\
     </tr><tr align="center"> <td width="350" class="message" colspan="2">The User Name and Password combination you have entered is invalid. Please try again.</td></tr>\
    <tr> <td class="caption" colspan="2">&nbsp;</td></tr>');
 }else{
   document.writeln(' ');
 }
}
</script>
</head>
<body bgcolor="#ffffff" text="#000000" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
<FORM method="post" ACTION="/login.html">
<INPUT TYPE="hidden" NAME="buttonClicked" SIZE="16" MAXLENGTH="15" VALUE="0">
<INPUT TYPE="hidden" NAME="err_flag" SIZE="16" MAXLENGTH="15" VALUE="0">
<INPUT TYPE="hidden" NAME="err_msg" SIZE="32" MAXLENGTH="31" VALUE="">
<INPUT TYPE="hidden" NAME="info_flag" SIZE="16" MAXLENGTH="15" VALUE="0">
<INPUT TYPE="hidden" NAME="info_msg" SIZE="32" MAXLENGTH="31" VALUE="">
<INPUT TYPE="hidden" NAME="redirect_url" SIZE="255" MAXLENGTH="255" VALUE="">
<table border="0" cellspacing=0 cellpading="0" width="100%">
   <tr>
     <td width="180" background="../../images/background_web41.jpg" align="middle" style="padding-bottom: 4px;" >

     <h1>Login</h1>
     </td>

     <td height="53" align="right" style="padding-bottom: 4px; padding-right: 20px;" background="../../images/background_web41.jpg"><div align="right"><img src="../../images/cisco/cisco-webauth-logo-2007.gif" width="67" height="40"></div></td>

   </tr>
   <tr>
        <td align="left" width="400">
        <div class="content">
            <table border="0" cellspacing="10" cellpadding="0">
            <tr>
                <td>
                    <table border="0" cellspacing="10" cellpadding="0">
                        <tr>
                            <th align="left" width="400">
                                Welcome to the Cisco wireless network
                            </th>
                        </tr>
                        <tr>
                            <td class="message" align="left" width="400">
                                Cisco is pleased to provide the Wireless LAN infrastructure for your network. Please login and put your unified wireless solution to work.  
                            </td>
                        </tr>
                    </table>
                </td>
            </tr>
                <script>
                    getErrorMsgIfAny();
                </script>
            <tr>
                <td>
                    <table border="0" cellspacing="10" cellpadding="0">
                        <tr>
                            <td width="100" nowrap>User Name</td>
                            <td>
                                <INPUT type="TEXT" name="username" SIZE="25" MAXLENGTH="80" VALUE="">
                            </td>
                        </tr>
                        <tr>
                            <td nowrap>Password</td>
                            <td>
                                <INPUT type="Password" name="password" emweb_type=PASSWORD autocomplete="off" EMWEB_TYPE=PASSWORD onKeyPress="submitOnEnter(event);" SIZE="25" MAXLENGTH="127" VALUE="">
                            </td>
                        </tr>
                        <tr>
                            <td>&nbsp;</td>
                            <td>
                                <script>getHtmlForButton("Submit","Submit","button","submitAction()"); </script>
                            </td>
                        </tr>
                    </table>
                </td>
             </tr>

            </table>
        </div>
        </td>
        <td align="right" >
            <table border="0" cellspacing="10" cellpadding="0" >
                <tr>
                    <td align="right" style="padding-top: 25px; padding-right: 20px;"
                        bgcolor="#ffffff" >
                    <div ></div></td>
                </tr>
            </table>   
        </td>
   </tr>
</table>
</FORM>
</body>
<HEAD>
<meta http-equiv="Cache-control" content="no-cache">
<meta http-equiv="Pragma" content="no-cache">
<meta http-equiv="Expires" content="-1">
</HEAD>
</html>


Reproducible: Always

Steps to Reproduce:
1. go to my customer with this router
2. start firefox
3. get automatic redirect to this page 
4. firefox crashes
5. manually type in https://1.1.1.1
6. firefox crashes too
Actual Results:  
firefox crash

Expected Results:  
receive a login window to authenticate to the router
The code provided does not crash Firefox 4 for me. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0 http://hg.mozilla.org/releases/mozilla-2.0/rev/6be9e31d01b4

Do you have any crash IDs from the Mozilla Crash Reporter? They can be found by typing about:crashes in the address bar. Then copy and paste the ids into this bug report. http://support.mozilla.com/en-US/kb/Mozilla Crash Reporter

Comment 4

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110411 Firefox/4.2a1pre

Works fine for me. Able to see the Login page.

Comment 6

7 years ago
Signature	strcmp | AuthCertificateCallback(void*, PRFileDesc*, int, int)
UUID	4fd9309b-6705-4891-ad89-7d2a12110411
Time 	2011-04-11 23:22:50.521675
Uptime	201
Last Crash	271 seconds (4.5 minutes) before submission
Install Age	1800112 seconds (3.0 weeks) since version was first installed.
Product	Firefox
Version	4.0
Build ID	20110318052756
Branch	2.0
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 6
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
User Comments	
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 95c4, AdapterDriverVersion: 8.641.1.0
D3D10 Layers? D3D10 Layers-
D3D9 Layers? D3D9 Layers-
Processor Notes 	
EMCheckCompatibility	False
Bugzilla - Report this Crash
Related Bugs

DUPLICATE

        Bug 644038 VERIFIED crash [@ strcmp | AuthCertificateCallback(void*, PRFileDesc*, int, int)]

FIXED

        Bug 644012 RESOLVED crash with an empty issuer name in SSL certificate, +leak fix [@ strcmp | AuthCertificateCallback(void*, PRFileDesc*, int, int)]

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	mozcrt19.dll 	strcmp 	strcmp.asm:81
1 	xul.dll 	AuthCertificateCallback 	security/manager/ssl/src/nsNSSCallbacks.cpp:1018
2 	ssl3.dll 	ssl3_HandleCertificate 	security/nss/lib/ssl/ssl3con.c:7905
3 	ssl3.dll 	ssl3_HandleHandshakeMessage 	security/nss/lib/ssl/ssl3con.c:8603
4 	ssl3.dll 	ssl3_HandleHandshake 	security/nss/lib/ssl/ssl3con.c:8727
5 	ssl3.dll 	ssl3_HandleRecord 	security/nss/lib/ssl/ssl3con.c:9066
6 	ssl3.dll 	ssl3_GatherCompleteHandshake 	security/nss/lib/ssl/ssl3gthr.c:209
7 	ssl3.dll 	ssl_GatherRecord1stHandshake 	security/nss/lib/ssl/sslcon.c:1258
8 	ssl3.dll 	ssl_Do1stHandshake 	security/nss/lib/ssl/sslsecur.c:151
9 	ssl3.dll 	ssl_SecureSend 	security/nss/lib/ssl/sslsecur.c:1213
10 	ssl3.dll 	ssl_SecureWrite 	security/nss/lib/ssl/sslsecur.c:1258
11 	ssl3.dll 	ssl_Write 	security/nss/lib/ssl/sslsock.c:1652
12 	xul.dll 	nsSSLThread::Run 	
13 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
14 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
15 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:348
16 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:326
17 	kernel32.dll 	BaseThreadInitThunk 	
18 	ntdll.dll 	__RtlUserThreadStart 	
19 	ntdll.dll 	_RtlUserThreadStart
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644012
Will be fixed in Firefox 4.0.1
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

7 years ago
Thanks, good to know.
You need to log in before you can comment on or make changes to this bug.