mac talos tests are not being scheduled for m-c builds

RESOLVED FIXED

Status

Release Engineering
General
--
critical
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: bear, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

7 years ago
from the #build irc conversation with Legneato:

[03:23]  <LegNeato> any chance you can look at http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302591974.1302592135.30555.gz ?
[03:23]  * bear looks
[03:23]  <LegNeato> with the new nightly branding we don't have mac talos runs
[03:23]  <LegNeato> becuase it is hardcoded to run Minefiled.app
[03:23]  <LegNeato> err Minefield.app that is
[03:23]  <LegNeato> I would imagine we'll have the same issue on Aurora tomorrow

dbaron in #developers thinks it may be for all m-c builds:

  <dbaron-sheriff> bear, I don't think the issue is just nightlies -- it's all m-c buids
[03:30]  <philor> dbaron-sheriff: nope, I've known about it for 12 minutes, and spent all of them looking in mxr and hg.m.o
[03:30]  <dbaron-sheriff> builds
[03:30]  <bear> k, then i'll make it more generic of a bug 
[03:31]  <philor> bear: bless our fun naming, the problem is that Nightly.app, which is the name of every build on mozilla-central, triggers but doesn't run right
(Reporter)

Updated

7 years ago
Severity: normal → critical

Comment 1

7 years ago
Created attachment 525328 [details] [diff] [review]
my stab at it
Attachment #525328 - Flags: review?(bhearsum)
My first guess about things is almost always wrong, my second quite often wrong, but I think what actually happened was that we switched branding, so we started building a Nightly.app in an objdir that still had a Minefield.app, which sometimes failed to compile, but sometimes succeeded, and then packaged up a dmg which contained both, and then the find command that searches out firefox-bin in the unpacked dmg found both of them, and tried to run talos on "./Minefield.app/Contents/MacOS/firefox-bin\n./Nightly.app/Contents/MacOS/firefox-bin" because we never expected to need to tell it to just find *one* firefox-bin.

So, since we clobbered to get rid of the build problems, this problem should, I think, also go away, except that we've burned opt Mac on every cset since then, so it'll still be a while before we actually know.
Comment on attachment 525328 [details] [diff] [review]
my stab at it

brand_name only affects old-style unittests, which we only run on 1.9.1 and 1.9.2, so I don't think this patch is necessary.
Attachment #525328 - Attachment is obsolete: true
Attachment #525328 - Flags: review?(bhearsum)
Things seem to be OK at this point, I see tons of tests running on both 10.5 and 10.6 opt and debug. So, Philor's explanation seems to have been correct: I don't see any issues after the clobber.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.