Last Comment Bug 649345 - Disabled Options Color changer
: Disabled Options Color changer
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: unspecified
: x86 Windows 7
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-12 08:26 PDT by lethedoom
Modified: 2011-04-22 05:04 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description lethedoom 2011-04-12 08:26:57 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Rainbowpicker 0.6 Disabled Options Color changer

Fail.It doesn't change page colors, but freezes/disables 'Options'-->'Content'->'Colors' functionality although it does replace the standard Firefox palette popup with an expanded palette. After going through the OKs nothing changes.I am on a Windows 7 PC using Firefox 4.0.

Reproducible: Always

Steps to Reproduce:
1.install Rainbowpicker 0.6
2.'Options'-->'Content'->'Colors' : expanded palette appears in place of standard pop up
3.Choose new background or text color. click appropriate OKs
Actual Results:  
No color change

Expected Results:  
change to chosen colors

It is possible to modify Firefox colors outside of the standard palette using Windows Advanced Appearance settings which demonstrates that Firefox does not forbid such modification. The add on purports to add that flexibility but disables the basic Options functionality instead demonstrating it is defective. If the add on is not compatible with Windows that should be stated clearly in the add ons page.
Comment 1 Kevin Brosnan [:kbrosnan] 2011-04-12 08:29:54 PDT
Toad would take a look at this user issue.
Comment 2 Michael Lelli 2011-04-12 14:05:25 PDT
Thanks for pointing this out. Some changes between Firefox 3.6 and 4.0 (possibly 3.5 and 3.6) made color changes in preference dialogs not update correctly. Version 0.6.1 should fix this.
Comment 3 lethedoom 2011-04-12 19:29:50 PDT
Version 6.1 works for me--I think this is fixed.
Comment 4 Kevin Brosnan [:kbrosnan] 2011-04-13 07:07:02 PDT
Fixed by Michael in v0.6.1.
Comment 5 George Carstoiu 2011-04-22 05:04:38 PDT
Verified on Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110421 Firefox/6.0a1

Note You need to log in before you can comment on or make changes to this bug.