Last Comment Bug 649428 - l10n repacks broken on all platforms on mozilla-central (probably aurora, too)
: l10n repacks broken on all platforms on mozilla-central (probably aurora, too)
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: All All
: -- blocker with 1 vote (vote)
: Firefox 5
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 649430 (view as bug list)
Depends on:
Blocks: 386760 649407
  Show dependency treegraph
 
Reported: 2011-04-12 11:20 PDT by Axel Hecht [pto-Aug-30][:Pike]
Modified: 2011-04-13 03:10 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
untested patch (3.95 KB, patch)
2011-04-12 12:34 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
robert.strong.bugs: review+
Details | Diff | Splinter Review
untested patch - comm-central (492 bytes, patch)
2011-04-12 12:36 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
kairo: review+
Details | Diff | Splinter Review

Description Axel Hecht [pto-Aug-30][:Pike] 2011-04-12 11:20:00 PDT
All repacks on mozilla-central are hosed right now, with something like

mv /builds/moz2_slave/cen-lnx-l10n-ntly/build/mozilla-central/browser/locales/../../dist/l10n-stage/firefox/chrome/be.manifest /builds/moz2_slave/cen-lnx-l10n-ntly/build/mozilla-central/browser/locales/../../dist/l10n-stage/firefox/chrome/localized.manifest
/builds/moz2_slave/cen-lnx-l10n-ntly/build/mozilla-central/config/nsinstall -D ../../dist/l10n-stage/
cd ../../dist/l10n-stage; \
	  (cd firefox && rm -f omni.jar components/binary.manifest && grep -h '^binary-component' components/*.manifest > binary.manifest ; sed -e 's/^binary-component/#binary-component/' components/components.manifest > components.manifest && mv components.manifest components && find . | xargs touch -t 201001010000 && zip -r9mX omni.jar chrome chrome.manifest components/*.js components/*.xpt components/*.manifest modules res defaults greprefs.js jsloader  -x chrome/icons/\* defaults/pref/channel-prefs.js res/cursors/\* res/MainMenu.nib/\*  && true && /tools/python/bin/python2.5 /builds/moz2_slave/cen-lnx-l10n-ntly/build/mozilla-central/browser/locales/../../config/optimizejars.py --optimize /builds/moz2_slave/cen-lnx-l10n-ntly/build/mozilla-central/browser/locales/../../dist/jarlog/ ./ ./ && mv binary.manifest components && printf "manifest components/binary.manifest\n" > chrome.manifest) && (cd firefox && /tools/python/bin/python2.5 ../../config/createprecomplete.py) && gtar -c --owner=0 --group=0 --numeric-owner --mode="go-w" -f - firefox | bzip2 -vf > firefox-4.2a1pre.be.linux-i686.tar.bz2
grep: components/*.manifest: No such file or directory
sed: can't read components/components.manifest: No such file or directory
make[1]: *** [repackage-zip] Error 2
make[1]: Leaving directory `/builds/moz2_slave/cen-lnx-l10n-ntly/build/mozilla-central/browser/locales'
make: *** [repackage-zip-be] Error 2
program finished with exit code 2
elapsedTime=2.841612
=== Output ended ===
======== BuildStep ended ========

or

  adding: jsloader/resource/services-sync/notifications.js.bin (deflated 59%)
  adding: jsloader/resource/services-sync/record.js.bin (deflated 63%)
  adding: jsloader/resource/services-sync/resource.js.bin (deflated 61%)
  adding: jsloader/resource/services-sync/service.js.bin (deflated 62%)
  adding: jsloader/resource/services-sync/status.js.bin (deflated 56%)
  adding: jsloader/resource/services-sync/util.js.bin (deflated 63%)
make[2]: Leaving directory `/e/builds/moz2_slave/cen-w32-l10n-ntly/build/mozilla-central/browser/locales'
make[1]: Leaving directory `/e/builds/moz2_slave/cen-w32-l10n-ntly/build/mozilla-central/browser/locales'
d:\mozilla-build\python25\python2.5.exe: can't open file '../../config/createprecomplete.py': [Errno 2] No such file or directory
make[2]: *** [repackage-zip] Error 2
make[1]: *** [repackage-win32-installer] Error 2
make: *** [repackage-win32-installer-bn-IN] Error 2
program finished with exit code 2
elapsedTime=36.968000

Possible candidates are robstrong and the exe unpack, I guess.
Comment 1 Axel Hecht [pto-Aug-30][:Pike] 2011-04-12 11:51:29 PDT
*** Bug 649430 has been marked as a duplicate of this bug. ***
Comment 2 Benjamin Smedberg [:bsmedberg] 2011-04-12 11:52:35 PDT
Is this the version bump? 4.2a1pre isn't the right file any more, right?
Comment 3 Ben Hearsum (:bhearsum) 2011-04-12 11:54:58 PDT
If they're broken on all platforms with the same error, I strongly suspect one of Rob Strong's patches, bug 313956 is Windows-only, and "createprecomplete.py" is a file that Rob added.
Comment 4 Axel Hecht [pto-Aug-30][:Pike] 2011-04-12 12:01:23 PDT
createprecomplete seems to show up in both linux and windows, looking at the tails of the two logs.

http://l10n.mozilla.org/~axel/nightlies/?date=2011-04-12 has links to tons of logs.
Comment 5 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 12:34:14 PDT
Created attachment 525471 [details] [diff] [review]
untested patch

I suspect that the new python script is running into the same problem as the jar optimize python script. If someone could check if this fixes it while I'm driving into the office I'd appreciate it.
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 12:36:14 PDT
Created attachment 525473 [details] [diff] [review]
untested patch - comm-central
Comment 7 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 14:53:59 PDT
Received r+=khuey over irc on the condition that I verify the fix locally
Comment 8 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 15:10:13 PDT
Comment on attachment 525473 [details] [diff] [review]
untested patch - comm-central

Going to need this on comm-central
Comment 9 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 15:12:08 PDT
Comment on attachment 525471 [details] [diff] [review]
untested patch

khuey r+'d this over irc and I verified this fixes win32 l10n repacks locally. I'm going to wait on the Mac nightly fix before landing these.
Comment 10 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 17:43:27 PDT
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/4a94c229c1a9

Pushed to mozilla-aurora (got a=LegNeato in person)
http://hg.mozilla.org/mozilla-aurora/rev/66aad63375e2
Comment 11 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 17:46:20 PDT
Comment on attachment 525473 [details] [diff] [review]
untested patch - comm-central

pushed to comm-central
http://hg.mozilla.org/comm-central/rev/16019fa784a3
Comment 12 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-12 18:44:28 PDT
bah... forgot to sync config.mk

Pushed followup to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/ec3461cc363e

Pushed followup to mozilla-aurora
http://hg.mozilla.org/mozilla-aurora/rev/555c56901907

Note You need to log in before you can comment on or make changes to this bug.