Closed Bug 649500 Opened 9 years ago Closed 9 years ago

Youtube's html5 player not working on newest nightly due to UA sniffing

Categories

(Tech Evangelism Graveyard :: English US, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: matjk7, Assigned: hsivonen)

References

Details

(Whiteboard: [fx6])

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110412 Firefox/6.0a1
Build Identifier: 

Apparently youtube is sniffing for Firefox/4.*, so the new Firefox/6.* builds don't get the html5 player.

Reproducible: Always
Has anyone bothered contacting YouTube and informing them that they really, really, really, REALLY shouldn't be sniffing for browser names but rather rendering engines?

http://geckoisgecko.org/

cl
(In reply to comment #1)
> Has anyone bothered contacting YouTube [...]

I gave it a shoot at http://www.google.com/support/forum/p/youtube/thread?tid=07924986d5ab8b8a FWIW
They are probably sniffing for something other than the UA string itself, because overriding the UA string doesn't help.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I sent a note to a venue where Google engineers can see it.
(In reply to comment #3)
> They are probably sniffing for something other than the UA string itself,
> because overriding the UA string doesn't help.

Something else could be e.g. window.navigator.vendorSub, but I didn't verify.
Google has a fix. I'll leave the bug open until the fix has been deployed.
Assignee: english-us → hsivonen
Duplicate of this bug: 649826
Re comment #3:  Be sure to clear all cookies related to the affected domain before attempting to spoof a bad sniffer.  The first step should be to shut down your browser to clear all session-only cookies.  

The problem is that sniffing often involves setting cookies to indicate what UA was detected.  Thereafter, sniffing is bypassed in favor of using the cookies.
Until we have a better way to track bugs which will be fixed on mozilla-central but not necessarily tied to a feature page, I'm using a whiteboard tag of [fxN]
Whiteboard: [fx6]
Apparently, "fixed on mozilla-central" was a bit confusing to some.  What I meant was that I need to be able to track bugs which will need verification during the scope of a particular cycle; regardless of whether its a firefox bug or not.

In this example, even though it's a Youtube bug, QA will still need to verify that it is working once Youtube claims it is fixed.

For now, QA has no better way to track these bugs in a single bucket without using the whiteboard tag.

Sorry about any confusion this has caused.
(In reply to comment #6)
> Google has a fix. I'll leave the bug open until the fix has been deployed.

Can anyone elaborate on what that fix is, and whether it will work for any Gecko browsers other than Firefox?
Looks like the fix has been deployed.  The HTML5 player works for me in a current nightly.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.