Last Comment Bug 649593 - TI+JM: v8 benchmark harness correctness bug
: TI+JM: v8 benchmark harness correctness bug
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
Depends on:
Blocks: infer-regress 649376
  Show dependency treegraph
 
Reported: 2011-04-13 01:32 PDT by Jan de Mooij [:jandem]
Modified: 2011-04-13 06:18 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (914 bytes, application/x-javascript)
2011-04-13 01:32 PDT, Jan de Mooij [:jandem]
no flags Details
Patch (1.75 KB, patch)
2011-04-13 02:35 PDT, Jan de Mooij [:jandem]
bhackett1024: review+
Details | Diff | Review

Description Jan de Mooij [:jandem] 2011-04-13 01:32:04 PDT
Created attachment 525641 [details]
Testcase

Attached testcase demonstrates the problem. It fails with -m -n -a:
test.js:20: Error: Assertion failed: got 0, expected 6326624
Comment 1 Jan de Mooij [:jandem] 2011-04-13 01:47:46 PDT
Reduced further:
--
function RunSingleBenchmark(data) {
    if (data == null)
        return { runs: 0, elapsed: 0 };
    data.runs += 10;
    return data;
}
var data;
data = RunSingleBenchmark(data);
data = RunSingleBenchmark(data);
assertEq(data.runs, 10);
--
Comment 2 Christian Holler (:decoder) 2011-04-13 01:56:17 PDT
Cannot be reproduced on 64 bit, seems to be a 32 bit only problem. Jan suggested it might be related to register allocation.
Comment 3 Jan de Mooij [:jandem] 2011-04-13 02:35:13 PDT
Created attachment 525646 [details] [diff] [review]
Patch

Use stubcc.masm to load atom pointer for OOL SetName call.
Comment 4 Brian Hackett (:bhackett) 2011-04-13 06:10:21 PDT
Comment on attachment 525646 [details] [diff] [review]
Patch

Oops. At least I remembered to store the atom at all!
Comment 5 Brian Hackett (:bhackett) 2011-04-13 06:18:01 PDT
Thanks!

http://hg.mozilla.org/projects/jaegermonkey/rev/2ad374159c49

Note You need to log in before you can comment on or make changes to this bug.