Closed Bug 649613 Opened 9 years ago Closed 8 years ago

Copying and pasting from the View Source window adds line breaks that weren't in the source

Categories

(Core :: Serializers, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 198391

People

(Reporter: hsivonen, Unassigned)

References

()

Details

Steps to reproduce:
 1) View Source on http://hsivonen.iki.fi/test/moz/view-source-bidi-break2.html
 2) Select all
 3) Copy
 4) Switch to a plain text editor (separate app that reads the plain text flavor from the system clipboard)
 5) Paste.

Expected results:
Expected the pasted result to have the line breaks that were in the original source and no more.

Actual results:
There's an extra line break wherever a new <pre> starts in the View Source DOM, because the plaintext serializer doesn't care about margin: 0 on pre.

Additional info:
This problem was caused by bug 86355.
Apparently dupe of bug 198391.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 198391
You need to log in before you can comment on or make changes to this bug.