Closed Bug 649714 Opened 9 years ago Closed 9 years ago

When copying code from code-boxes, line breaks does not come along

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 116083

People

(Reporter: sehm.younes, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Code copied from <div class="code-box">line1
line2
line3</div> results with "line1 line2 line3" in the clipboard, without line breaks as it should.

Reproducible: Always

Steps to Reproduce:
1. Go to the site provided.
2. Scroll down to "Step 3".
3. Mark any amount of text from the code eample.
4. Press CTRL+C
5. Open up notepad/gedit/anything
6. Paste there and watch the badly formated code.
Actual Results:  
See step 5 and 6 above.

Expected Results:  
The pasted code should have been formatted with respect to line breaks as the code was formatted in the browser.

Other browsers does not produce that formatting. This one is probably super-duper-easy to patch by just concatenating a "\n" for each line processed/copied from the site source.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 116083
You need to log in before you can comment on or make changes to this bug.