Closed Bug 649754 Opened 9 years ago Closed 9 years ago

update dialog no longer centered

Categories

(Toolkit :: Application Update, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla5
Tracking Status
firefox5 + fixed

People

(Reporter: rstrong, Assigned: rstrong)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached patch simple fixSplinter Review
Add back the call to CenterDialog
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #525767 - Flags: review?(dtownsend)
Simple fix, just adds back a function call that was accidentally removed. I think we want this on Aurora
How far is it off? Can it get off screen?
Attachment #525767 - Flags: review?(dtownsend) → review+
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/704c27a2a2e4

Don't think we need tests for this. Besides it being a royal pita to create tests for this every Windows nightly update sees this ui so it is hard to miss.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Flags: in-litmus-
Resolution: --- → FIXED
Comment on attachment 525767 [details] [diff] [review]
simple fix

Restores one line of code that was accidentally removed in the rush to get bug 386760 landed for Aurora. Risks are extremely negligible since this is the same code that is on several releases.
Attachment #525767 - Flags: approval-mozilla-aurora?
I think we must have this in Aurora. Without it, the dialog is slammed into the top left of the desktop. That's not a shippable regression IMO.
Attachment #525767 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.