Last Comment Bug 649983 - Use more vertical space for dialogs
: Use more vertical space for dialogs
Status: VERIFIED FIXED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: x86 Linux
: P3 normal (vote)
: Firefox 7
Assigned To: Wesley Johnston (:wesj)
:
Mentors:
: 658938 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 07:06 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2011-07-18 14:24 PDT (History)
9 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot (35.54 KB, image/jpeg)
2011-04-14 07:09 PDT, Cristian Nicolae (:xti)
no flags Details
example of unused area above and below dialog (87.71 KB, image/jpeg)
2011-04-14 07:10 PDT, Mark Finkle (:mfinkle) (use needinfo?)
no flags Details
HackyPatch (1.12 KB, patch)
2011-06-02 10:07 PDT, Wesley Johnston (:wesj)
mark.finkle: review+
Details | Diff | Splinter Review
Nightly (06/14) (28.87 KB, image/png)
2011-06-14 07:49 PDT, Aaron Train [:aaronmt]
no flags Details
Gingerbread Patch (439 bytes, patch)
2011-06-14 10:21 PDT, Wesley Johnston (:wesj)
mark.finkle: review+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-04-14 07:06:41 PDT
The dialog theme changes in Bug 618989 reduced the maxHeight we use on dialogs, limiting the amount of content we can show in a large dialog.

Let's extend the maxHeight to match the margin on the width.
Comment 1 Cristian Nicolae (:xti) 2011-04-14 07:09:14 PDT
Created attachment 525986 [details]
screenshot
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-04-14 07:10:17 PDT
Created attachment 525987 [details]
example of unused area above and below dialog

You can see in this screenshot that the dialog content is limited because of the extra space left above and below the dialog.

Using more vertical space will help some dialogs display more content.
Comment 3 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-04-21 06:25:23 PDT
This happens because of rule
.perm-modal-block {
  -moz-box-align: center;
}

This rule force the box to fit the size of it's content but fail for some reason in this case.
I don't think we want to remove this rule since it makes things simplier for all the other dialogs. For example adding some padding at the bottom of the box with the class prompt-message fix this bug (not sure why thouhg)
Comment 4 Tony Chung [:tchung] 2011-05-23 10:15:59 PDT
*** Bug 658938 has been marked as a duplicate of this bug. ***
Comment 5 Philipp von Weitershausen [:philikon] 2011-05-23 10:19:16 PDT
Plz to be fixing this for Firefox 5 kthxbai :)
Comment 6 Wesley Johnston (:wesj) 2011-06-02 10:07:14 PDT
Created attachment 536915 [details] [diff] [review]
HackyPatch

Hack to add pading like vivien suggested, and only apply it to the sync dialog.
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-02 10:35:28 PDT
Comment on attachment 536915 [details] [diff] [review]
HackyPatch

Tested on nexus one or some device that showed it fixed the issues, I assume
Comment 8 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-06-03 02:19:55 PDT
A small comment before check-in would be nice if we don't want this hack to be removed during a clean-up.
Comment 9 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-06-03 04:09:44 PDT
http://hg.mozilla.org/mozilla-central/rev/414c88582e9f
Comment 10 Aaron Train [:aaronmt] 2011-06-14 07:49:27 PDT
Created attachment 539206 [details]
Nightly (06/14)

Is this correct? See attached screenshot. Looks like it still needs a height tweak adjustment.
Comment 11 Philipp von Weitershausen [:philikon] 2011-06-14 08:22:58 PDT
(In reply to comment #10)
> Is this correct? See attached screenshot.

No. I see no change at all! Should we reopen?
Comment 12 Wesley Johnston (:wesj) 2011-06-14 08:26:25 PDT
probably due to the gingerbread theme
Comment 13 Wesley Johnston (:wesj) 2011-06-14 10:21:03 PDT
Created attachment 539243 [details] [diff] [review]
Gingerbread Patch

Follow up patch for gingerbread.
Comment 14 Matt Brubeck (:mbrubeck) 2011-06-15 10:01:13 PDT
Gingerbread patch merged from mozilla-inbound to mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/e10723691732
Comment 15 Aaron Train [:aaronmt] 2011-06-16 07:01:40 PDT
Verified fixed
Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110616 Firefox/7.0a1 Fennec/7.0a1

Note You need to log in before you can comment on or make changes to this bug.