Last Comment Bug 650235 - Assignment instead of comparison in nsOuterDocAccessible::GetChildAtPoint
: Assignment instead of comparison in nsOuterDocAccessible::GetChildAtPoint
Status: VERIFIED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
:
Mentors:
Depends on:
Blocks: 641562
  Show dependency treegraph
 
Reported: 2011-04-15 05:16 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-07-27 04:58 PDT (History)
4 users (show)
Ms2ger: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch v1 (848 bytes, patch)
2011-04-15 05:16 PDT, :Ms2ger (⌚ UTC+1/+2)
surkov.alexander: review+
bugzilla: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-04-15 05:16:03 PDT
Created attachment 526222 [details] [diff] [review]
Patch v1
Comment 1 alexander :surkov 2011-04-15 19:21:49 PDT
Comment on attachment 526222 [details] [diff] [review]
Patch v1

thank you for the catch!
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2011-04-17 05:51:29 PDT
Thanks.

http://hg.mozilla.org/mozilla-central/rev/e94c6b74164f
Comment 3 Marco Zehe (:MarcoZ) 2011-04-17 22:46:26 PDT
Do we want this for Aurora?
Comment 4 Johnny Stenback (:jst, jst@mozilla.com) 2011-04-19 15:43:26 PDT
What's the risk/reward for taking this? If this is super safe and the reward is high, please nominate the patch.
Comment 5 alexander :surkov 2011-04-19 22:42:54 PDT
it's super safe. Not sure about reward though, I should know AT internals dor that. Under certain circumstances the deepest child is returned instead the direct child. Marco?
Comment 6 Marco Zehe (:MarcoZ) 2011-05-02 03:00:47 PDT
It would account for some inconsistencies I've seen with NVDA. But I've been running with the Nightly for a few days and didn#t notice any difference so far. But I'm nominating it anyway since this will improve things in some instances, and this is a regression introduced in FX4 IIRC.
Comment 7 Marco Zehe (:MarcoZ) 2011-05-02 03:38:14 PDT
Comment on attachment 526222 [details] [diff] [review]
Patch v1

Nominating the patch, see previous comment.
Comment 8 Johnathan Nightingale [:johnath] 2011-05-04 12:01:03 PDT
Comment on attachment 526222 [details] [diff] [review]
Patch v1

Heh. A=me
Comment 9 Marco Zehe (:MarcoZ) 2011-05-05 06:12:37 PDT
I took the liberty of landing this on Ms2ger's behalf on Aurora:
http://hg.mozilla.org/mozilla-aurora/rev/389bc8414daf
Comment 10 AndreiD[QA] 2011-07-27 04:58:09 PDT
The fix (comparison instead of assignment for the variables aWhichChild and eDeepestChild) is visible in the hg for latest beta build
Setting this as Verified for Firefox 6 Beta:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0

Note You need to log in before you can comment on or make changes to this bug.