Last Comment Bug 650246 - Replace %APP% with firefox in firefox preferences
: Replace %APP% with firefox in firefox preferences
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 6
Assigned To: Mike Hommey [:glandium]
:
: Jared Wein [:jaws] (please needinfo? me)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-15 06:12 PDT by Mike Hommey [:glandium]
Modified: 2011-06-12 02:38 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (7.68 KB, patch)
2011-04-15 06:12 PDT, Mike Hommey [:glandium]
gavin.sharp: review+
Details | Diff | Splinter Review
Replace %APP% with "firefox" in Firefox preferences. (7.96 KB, patch)
2011-05-08 22:39 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-04-15 06:12:50 PDT
Created attachment 526227 [details] [diff] [review]
Patch

This is something I have been doing for a while on Debian, where %APP% resolves to iceweasel, yet hadn't bothered filing a bug until now that I saw bug 602367 comment 15:

>> Why aren't we using '?src=%APP%' here?
>
> It's in the Firefox prefs so I don't think there is much to be gained from
> changing that now.

With the same rationale, it should be safe to replace %APP% with firefox in the same file.
Comment 1 Dave Townsend [:mossop] 2011-04-19 10:10:28 PDT
Comment on attachment 526227 [details] [diff] [review]
Patch

My comment was more because we were pushed for time so I didn't think it worth bothering with, not necessarily that we should do it everywhere but I'll let one of the browser peers make that call.
Comment 2 Mike Hommey [:glandium] 2011-05-08 22:39:27 PDT
Created attachment 530986 [details] [diff] [review]
Replace %APP% with "firefox" in Firefox preferences.

As landed
Comment 3 Mike Hommey [:glandium] 2011-05-08 22:43:21 PDT
http://hg.mozilla.org/mozilla-central/rev/9e31df64bfd7

Note You need to log in before you can comment on or make changes to this bug.