Last Comment Bug 650263 - Build the test plugin on GNU/kfreebsd
: Build the test plugin on GNU/kfreebsd
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All Other
: -- normal (vote)
: mozilla6
Assigned To: Mike Hommey [:glandium]
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-15 06:50 PDT by Mike Hommey [:glandium]
Modified: 2011-04-22 01:35 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (586 bytes, patch)
2011-04-15 06:50 PDT, Mike Hommey [:glandium]
ted: review-
Details | Diff | Splinter Review
Patch v2 (574 bytes, patch)
2011-04-15 07:24 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review
Patch as landed (590 bytes, patch)
2011-04-22 01:35 PDT, Mike Hommey [:glandium]
mh+mozilla: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-04-15 06:50:40 PDT
Created attachment 526236 [details] [diff] [review]
Patch

cf. summary
Comment 1 Ted Mielczarek [:ted.mielczarek] 2011-04-15 07:18:39 PDT
Comment on attachment 526236 [details] [diff] [review]
Patch

I think this line is wrong as it stands. The test plugin is widget-toolkit dependent, not OS-dependent:
http://mxr.mozilla.org/mozilla-central/source/modules/plugin/test/testplugin/Makefile.in

so we should change this to be a whitelist of widget toolkits that it supports, which should fix your problem by default, since you're targeting gtk2.
Comment 2 Mike Hommey [:glandium] 2011-04-15 07:24:31 PDT
Created attachment 526247 [details] [diff] [review]
Patch v2

Completely agreed.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-04-15 07:54:07 PDT
Comment on attachment 526247 [details] [diff] [review]
Patch v2

What's OS2's toolkit value? I'm too lazy to look it up. You probably should include that.
Comment 4 Mike Hommey [:glandium] 2011-04-15 08:07:03 PDT
You actually made me look around, and now I'm wondering about qt...
Comment 5 Mike Hommey [:glandium] 2011-04-22 01:34:59 PDT
http://hg.mozilla.org/mozilla-central/rev/c4b82ec27d6d
Comment 6 Mike Hommey [:glandium] 2011-04-22 01:35:46 PDT
Created attachment 527739 [details] [diff] [review]
Patch as landed

Note You need to log in before you can comment on or make changes to this bug.