rel-192-mu was not marked for clobbering

RESOLVED DUPLICATE of bug 676534

Status

Release Engineering
Release Automation: Other
P3
normal
RESOLVED DUPLICATE of bug 676534
7 years ago
5 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [known release issue], URL)

(Reporter)

Description

7 years ago
I triggered the MU for 3.6.17 and I got an error saying that there is already a directory inside the builder.
I looked into the clobberer step's output and I noticed that the only builder that had a clobber date different than 04-14 was the rel-192-mu.

I don't know enough the code to try to fix this.

> perl patcher2.pl --build-tools-hg --tools-revision=UPDATE_PACKAGING_R11_1_MU --app=firefox --brand=Firefox --config=patcher-configs/moz192-branch-major-update-patcher2.cfg
> ...
> read_past_updates(): Invalid past-update specification: 
> IN SHUTDOWN...
> ERROR: /builds/slave/rel-192-mu/build/mozilla exists.  Please move it away before continuing! > at patcher2.pl line 197.


> python rel-192-mu/tools/clobberer/clobberer.py -s tools http://build.mozilla.org/clobberer/index.php mozilla-2.0 release-mozilla-1.9.2-major_update rel-192-mu mv-moz2-linux-ix-slave14 http://production-master03.build.mozilla.org:8010/
> ...
> Checking clobber URL: http://build.mozilla.org/clobberer/index.php?master=http%3A%2F%2Fproduction-master03.build.mozilla.org%3A8010%2F&slave=mv-moz2-linux-ix-slave14&builddir=rel-192-mu&branch=mozilla-2.0&buildername=release-mozilla-1.9.2-major_update
/builds/slave/cen-mb-br-maemo5-gtk-bld doesn't exist, skipping
> ...
> rel-192-source:Our last clobber date:  2011-04-14 08:02:49
> rel-192-source:Server clobber date:    2011-04-14 08:02:49
> rel-192-mu:Our last clobber date:  2011-03-20 02:50:00
> rel-192-mu:Server clobber date:    2011-03-18 12:27:25
> ...
> rel-192-updates:Our last clobber date:  2011-04-14 08:02:49
> rel-192-updates:Server clobber date:    2011-04-14 08:02:49
> rel-192-lnx-rpk-6:Our last clobber date:  2011-04-14 08:02:49
> rel-192-lnx-rpk-6:Server clobber date:    2011-04-14 08:02:49
> rel-192-lnx-rpk-5:Our last clobber date:  2011-04-14 08:02:49
> rel-192-lnx-rpk-5:Server clobber date:    2011-04-14 08:02:49
> ...
> rel-192-tag:Our last clobber date:  2011-04-14 08:02:49
> rel-192-tag:Server clobber date:    2011-04-14 08:02:49
(Reporter)

Updated

7 years ago
Priority: -- → P3
Whiteboard: [known release issue]
No longer blocks: 714371
Mass move of bugs to Release Automation component.
Blocks: 714371
Component: Release Engineering → Release Engineering: Automation (Release Automation)
No longer blocks: 714371
Forward duping to bug 676534 because it has a bit better data in it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 676534
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.