"Firefox" is hardcoded in appstrings.properties

RESOLVED DUPLICATE of bug 336029

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 336029
7 years ago
7 years ago

People

(Reporter: glandium, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 526245 [details] [diff] [review]
Patch using MOZ_APP_DISPLAYNAME

This is something that has been bothering me for a while now. In the past, I was patching appstrings.properties, replacing Firefox with Iceweasel (guess why? ;) ). Recently, I changed that to use the MOZ_APP_DISPLAYNAME build variable, but I'm not sure it plays well with the l10n stuff. I'm attaching that patch for reference.

This actually has more impact than on Iceweasel. For instance, previously with Minefield, and now with Nightly and Aurora, you get inconsistent network error messages. For example, if I go to http://localhost:1234 with a Nightly, this is what I can read:

  Firefox can't establish a connection to the server at localhost:1234.
  (snip)
  If your computer or network is protected by a firewall or proxy, make sure
  that Nightly is permitted to access the Web.

For the record, a while ago, I attempted to generically fix this using numbered parameters in the strings, as these strings are actually being formatted in the netwerk code, using parameters. For compatibility purpose, I tried to keep the current parameters at the same index, but it turns out that the formatting code doesn't like formatting strings with, e.g. %3$S when there is no %2$S in the string. By the way, it looks like the application name is actually now passed as 3rd parameter, cf. the externalProtocolPrompt string. So maybe a solution would be to fix the formatting functions to allow %3$S when there is no %2$S in the format string, and replace Firefox with %3$S ?
(Reporter)

Updated

7 years ago
Blocks: 659568
No longer blocks: 659568

Updated

7 years ago
Blocks: 682414
No longer blocks: 682414
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 336029
You need to log in before you can comment on or make changes to this bug.