Rename all things Tryserver/MozillaTry to just Try in order to have uniform naming from repo-name on down

RESOLVED FIXED

Status

Release Engineering
Other
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: catlee, Assigned: lsblakk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(9 attachments, 2 obsolete attachments)

30.32 KB, patch
catlee
: review+
Details | Diff | Splinter Review
33.19 KB, patch
lsblakk
: checked-in+
Details | Diff | Splinter Review
13.58 KB, patch
Details | Diff | Splinter Review
11.47 KB, patch
aki
: review+
lsblakk
: checked-in+
Details | Diff | Splinter Review
6.48 KB, patch
aki
: review+
lsblakk
: checked-in+
Details | Diff | Splinter Review
951 bytes, patch
dustin
: review+
Details | Diff | Splinter Review
23.93 KB, patch
aki
: review+
lsblakk
: checked-in+
Details | Diff | Splinter Review
5.99 KB, patch
aki
: review+
lsblakk
: checked-in+
Details | Diff | Splinter Review
854 bytes, patch
lsblakk
: review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
Not sure how long this has been happening. It's breaking reporting of talos results for try:

FAIL: Graph server unreachable (5 attempts)
RETURN:send failed, graph server says:
RETURN:No branch_id for a branch_name 'MozillaTry' can be found
RETURN:  File "/data/www/graphs.mozilla.org/server/pyfomatic/collect.py", line 264, in handleRequest
RETURN:    metadata = MetaDataFromTalos(databaseCursor, databaseModule, inputStream)
RETURN:  File "/data/www/graphs.mozilla.org/server/pyfomatic/collect.py", line 59, in __init__
RETURN:    self.doDatabaseThings(databaseCursor)
RETURN:  File "/data/www/graphs.mozilla.org/server/pyfomatic/collect.py", line 109, in doDatabaseThings
RETURN:    raise DatabaseException("No branch_id for a branch_name '%s' can be found" % self.branch_name)
(Assignee)

Updated

6 years ago
Assignee: nobody → lsblakk
this blocks resolving 628561
Blocks: 628561
is a fix for this still on the radar?
(Assignee)

Updated

6 years ago
Summary: Try talos sending results to MozillaTry instead of Tryserver → Rename all things Tryserver/MozillaTry to just Try in order to have uniform naming from repo-name on down
(Assignee)

Comment 3

6 years ago
To make things like this less likely to happen, I've morphed this bug into a tracking bug where I'll document moving all things tryserver over to just try to match the repo name which is what all other branches do (or should).

Repo Name / Branch Name / Tinderbox tree name / Graphserver entry will all be just "Try"
(Assignee)

Updated

6 years ago
Depends on: 651513
(Assignee)

Comment 4

6 years ago
Created attachment 527281 [details] [diff] [review]
data.sql patch for renaming Tryserver -> Try
Attachment #527281 - Flags: review?(catlee)
(Reporter)

Updated

6 years ago
Attachment #527281 - Flags: review?(catlee) → review+
(Assignee)

Comment 5

6 years ago
Created attachment 527294 [details] [diff] [review]
renaming 'tryserver' to 'try' across the board

this will require at the very least, notice, and at most a small try downtime since it will change where the builds go to try-builds instead of tryserver-builds
Attachment #527294 - Flags: review?(catlee)
(Assignee)

Updated

6 years ago
Blocks: 651524
(Assignee)

Updated

6 years ago
Blocks: 651513
No longer depends on: 651513
the changes from bug 651513 caused some fallout.

http://tbpl.mozilla.org/?tree=MozillaTry&rev=15a61bf47863
(Reporter)

Updated

6 years ago
Duplicate of this bug: 651934
(Reporter)

Comment 8

6 years ago
Comment on attachment 527294 [details] [diff] [review]
renaming 'tryserver' to 'try' across the board

so far so good.

I think we need to rename the mozconfigs too?
Attachment #527294 - Flags: review?(catlee) → review+
(Assignee)

Comment 9

6 years ago
Created attachment 527795 [details] [diff] [review]
renaming 'tryserver' to 'try' across the board v2 with mozconfigs

renamed tryserver mozconfigs to try
Created attachment 527797 [details] [diff] [review]
renaming 'tryserver' to 'try' across the board v2 with mozconfigs

and now, from the right dir.
Attachment #527795 - Attachment is obsolete: true
Comment on attachment 527797 [details] [diff] [review]
renaming 'tryserver' to 'try' across the board v2 with mozconfigs

http://hg.mozilla.org/build/buildbot-configs/rev/af01d1e2040a
Attachment #527797 - Flags: checked-in+
(Assignee)

Updated

6 years ago
Blocks: 651027
landed http://hg.mozilla.org/hgcustom/hghooks/rev/e3e66525453c and reopened bug 651027 to request a treeclosure hook update.
(Assignee)

Updated

6 years ago
Depends on: 652173
Created attachment 527822 [details] [diff] [review]
data.sql patch for renaming Tryserver -> Try

this one includes renaming the machines
Attachment #527281 - Attachment is obsolete: true
landed a bustage fix renaming the mobile configs too: http://hg.mozilla.org/build/buildbot-configs/rev/82171f0757f7
Created attachment 527827 [details] [diff] [review]
try renaming buildbotcustom changes
Attachment #527827 - Flags: review?(aki)
Created attachment 527828 [details] [diff] [review]
try renaming in post_upload.py
Attachment #527828 - Flags: review?(aki)

Updated

6 years ago
Attachment #527827 - Flags: review?(aki) → review+

Comment 17

6 years ago
Comment on attachment 527828 [details] [diff] [review]
try renaming in post_upload.py

As mentioned in IRC, we need to fix the NFS mounts, create the upload try-builds dir, and fix the crontabs on stage.
Attachment #527828 - Flags: review?(aki) → review+
(Assignee)

Updated

6 years ago
Depends on: 652208
Comment on attachment 527827 [details] [diff] [review]
try renaming buildbotcustom changes

http://hg.mozilla.org/build/buildbotcustom/rev/c5d45a4431bd
Attachment #527827 - Flags: checked-in+
Comment on attachment 527828 [details] [diff] [review]
try renaming in post_upload.py

http://hg.mozilla.org/build/tools/rev/dcadfa6a1bb2
Attachment #527828 - Flags: checked-in+
Created attachment 527850 [details] [diff] [review]
puppet patch for new staging dir
Attachment #527850 - Flags: review?(dustin)
Comment on attachment 527850 [details] [diff] [review]
puppet patch for new staging dir

Looks fine.  To deploy, land and 'hg pull -u' in /etc/puppet/manifests on all five puppet masters.  Then figure out if surf runs puppet regularly, and if it doesn't, run it manually or just make the change manually.

Note that your patch will not delete the old tryserver-builds directory.  You could do that by puppet or by hand.
Attachment #527850 - Flags: review?(dustin) → review+
Created attachment 527869 [details] [diff] [review]
updates the try_parser test suite for 'try'
Attachment #527869 - Flags: review?(aki)

Updated

6 years ago
Attachment #527869 - Flags: review?(aki) → review+
Created attachment 527870 [details] [diff] [review]
fix try_sendchange.py
Comment on attachment 527870 [details] [diff] [review]
fix try_sendchange.py

tested on pm02 with my try push
Attachment #527870 - Flags: review?(aki)

Comment 25

6 years ago
Comment on attachment 527870 [details] [diff] [review]
fix try_sendchange.py

>+            tryDirPath = TRY_BASE_PATH % {'email': email, 
>                                                   'changeset': changeset}

Nit: I'd like this to line up.

>-                    tryserverUrlPath = PLATFORM_BASE_PATH % {'email': email, 
>+                    tryUrlPath = PLATFORM_BASE_PATH % {'email': email, 
>                                                           'changeset': changeset, 
>                                                           'platform': platform}

This too.
Attachment #527870 - Flags: review?(aki) → review+
Comment on attachment 527870 [details] [diff] [review]
fix try_sendchange.py

http://hg.mozilla.org/build/tools/rev/2bc0a26954d0

landed and updated pm{01,02,03} where try_sendchange is in the ~ dir.
Attachment #527870 - Flags: checked-in+
Comment on attachment 527869 [details] [diff] [review]
updates the try_parser test suite for 'try'

landed on default, it can be picked up in the next merge - no rush
http://hg.mozilla.org/build/buildbotcustom/rev/50d0d3dfcd09
Attachment #527869 - Flags: checked-in+
I'm not sure why we had to change the ftp directories for try server, but one thing you'll want to do as a result is file a bug on tbpl so that the "go to build directory" will point to the correct place.
Depends on: 652451
I'm gonna love him, and hug him, and pet him, and call him bug 652451.
I think we're done here.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Created attachment 540862 [details] [diff] [review]
fix lib/python/build/upload.py

This should fix lib/python/build/upload.py
Attachment #540862 - Flags: review?(lsblakk)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

6 years ago
Attachment #540862 - Flags: review?(lsblakk) → review+
Comment on attachment 540862 [details] [diff] [review]
fix lib/python/build/upload.py

http://hg.mozilla.org/build/tools/rev/b383a186ba79
Attachment #540862 - Flags: checked-in+
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
https://hg.mozilla.org/hgcustom/version-control-tools/rev/95aa2282865f
You need to log in before you can comment on or make changes to this bug.