Closed Bug 650299 Opened 9 years ago Closed 4 years ago

Don't leak the proxy call trap with Function.prototype.toString

Categories

(Core :: JavaScript Engine, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 1100936

People

(Reporter: evilpie, Unassigned)

References

Details

For some reason, we currently call the toString method of the caller trap directly, which leaks the call trap source. Wladmir Palant recognized this an issue here:http://adblockplus.org/blog/do-javascript-proxies-allow-undetectable-function-wrappers. Maybe we can just call get Trap with "toString".
Blocks: abp
Assignee: general → nobody
Fixed in http://hg.mozilla.org/mozilla-central/rev/b4c5e8bcb819 (bug 1100936).
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100936
You need to log in before you can comment on or make changes to this bug.