Last Comment Bug 650451 - Associate the application with playable media types on Mac
: Associate the application with playable media types on Mac
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Shell Integration (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: Firefox 7
Assigned To: David Humphrey (:humph)
:
: Robert Strong [:rstrong] (use needinfo to contact me)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-15 20:01 PDT by David Humphrey (:humph)
Modified: 2011-06-02 05:07 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (1.87 KB, patch)
2011-04-15 20:02 PDT, David Humphrey (:humph)
ted: review+
smichaud: review+
Details | Diff | Splinter Review
Updated patch, ready for landing (1.84 KB, patch)
2011-05-27 13:13 PDT, David Humphrey (:humph)
no flags Details | Diff | Splinter Review

Description David Humphrey (:humph) 2011-04-15 20:01:18 PDT
Firefox can play ogg, oga, ogv, and webm media files, but it doesn't appear as a Recommended Application when you try to open one of these (right-click media file, Open With...).  Chrome does the right thing and provides associations (my Mac currently has Chromium claiming to be the default app for .ogg files, despite me never setting that).  We need to do the same.
Comment 1 David Humphrey (:humph) 2011-04-15 20:02:37 PDT
Created attachment 526452 [details] [diff] [review]
Fix

Here's a fix.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-04-22 05:46:43 PDT
Comment on attachment 526452 [details] [diff] [review]
Fix

Looks okay to me, but you should probably have a Mac guru sign off on it.
Comment 3 Steven Michaud [:smichaud] (Retired) 2011-04-22 13:40:41 PDT
Comment on attachment 526452 [details] [diff] [review]
Fix

This also looks fine to me ... though I haven't tested it.

Here's Apple's "Information Property List Key Reference":
http://developer.apple.com/library/mac/#documentation/General/Reference/InfoPlistKeyReference/Introduction/Introduction.html

I include it because it's rather hard to find.

And here's the most relevant part of it:
http://developer.apple.com/library/mac/#documentation/General/Reference/InfoPlistKeyReference/Articles/CoreFoundationKeys.html
Comment 4 David Humphrey (:humph) 2011-05-21 13:57:58 PDT
I've tested it, and it works.  I'm assuming with these two r+s I'm good to go?  Setting checkin-needed, please remove if I need another level of review from someone.
Comment 5 Dão Gottwald [:dao] 2011-05-22 00:31:48 PDT
patching file browser/app/macbuild/Contents/Info.plist.in
Hunk #1 FAILED at 64
1 out of 1 hunks FAILED -- saving rejects to file browser/app/macbuild/Contents/Info.plist.in.rej
Comment 6 David Humphrey (:humph) 2011-05-27 13:13:51 PDT
Created attachment 535726 [details] [diff] [review]
Updated patch, ready for landing
Comment 7 Dão Gottwald [:dao] 2011-05-28 05:50:53 PDT
http://hg.mozilla.org/mozilla-central/rev/056d9d131d5c
Comment 8 Simona B [:simonab ] 2011-06-02 05:07:14 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0a1) Gecko/20110601 Firefox/7.0a1

Verified that Firefox appear as a recommended application when you try to open a video.

Note You need to log in before you can comment on or make changes to this bug.