"ASSERTION: Creating ContinuingTextFrame, but there is no more content"

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: smontagu)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 526470 [details]
testcase

###!!! ASSERTION: Creating ContinuingTextFrame, but there is no more content: 'mContentOffset < PRInt32(aContent->GetText()->GetLength())', file layout/generic/nsTextFrameThebes.cpp, line 3743

Strangely, the testcase has to be XHTML.  Standards-mode HTML doesn't trigger the bug.
(Reporter)

Updated

6 years ago
Attachment #526470 - Attachment mime type: text/html → application/xhtml+xml
(Reporter)

Comment 1

6 years ago
Created attachment 526471 [details]
stack trace
(Assignee)

Comment 2

6 years ago
This is caused by http://hg.mozilla.org/mozilla-central/rev/2ad43389d244
Assignee: nobody → smontagu
(Reporter)

Updated

6 years ago
Blocks: 263359
Keywords: regression
(Assignee)

Comment 3

6 years ago
Created attachment 526570 [details] [diff] [review]
Patch
Attachment #526570 - Flags: review?(roc)
Attachment #526570 - Flags: review?(roc) → review+
(Assignee)

Comment 4

6 years ago
I folded the fix and testcase into http://hg.mozilla.org/mozilla-central/rev/3d475b322365 when rechecking in bug 263359
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.