The default bug view has changed. See this FAQ.

Build --with-libxul-sdk is broken

RESOLVED FIXED in mozilla6

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ojab, Assigned: ojab)

Tracking

Trunk
mozilla6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

795 bytes, patch
glandium
: review+
Details | Diff | Splinter Review
(Assignee)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110415 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110415 Firefox/6.0a1

Firefox build using --with-libxul-sdk=../xulrunner/dist ends up with error:

make[7]: Вход в каталог `/home/ojab/opt/browser/services/crypto'
/usr/bin/python2.7 /sources/mozilla-central/config/nsinstall.py /sources/mozilla-central/services/crypto/modules/* ../../dist/bin/modules/services-crypto
IWeaveCrypto.idl
/home/ojab/opt/xulrunner/dist/bin/xpidl -m typelib -w -I/sources/mozilla-central/services/crypto -I../../dist/idl -I/home/ojab/opt/xulrunner/dist/idl -e _xpidlgen/IWeaveCrypto.xpt -d .deps/IWeaveCrypto.pp /sources/mozilla-central/services/crypto/IWeaveCrypto.idl
/usr/bin/python2.7 ../../dist/sdk/bin/xpt.py link _xpidlgen/services-crypto.xpt _xpidlgen/IWeaveCrypto.xpt
/usr/bin/python2.7: can't open file '../../dist/sdk/bin/xpt.py': [Errno 2] No such file or directory
make[7]: *** [_xpidlgen/services-crypto.xpt] Ошибка 2

because xpt.py exists only in xulrunner objdir.

With hack
-XPIDL_LINK = $(PYTHON) $(SDK_BIN_DIR)/xpt.py link
+XPIDL_LINK = $(PYTHON) $(LIBXUL_DIST)/sdk/bin/xpt.py link
firefox builds fine (but I don't think that it is proper fix).


Reproducible: Always
(Assignee)

Updated

6 years ago
Blocks: 643817
(In reply to comment #0)
> With hack
> -XPIDL_LINK = $(PYTHON) $(SDK_BIN_DIR)/xpt.py link
> +XPIDL_LINK = $(PYTHON) $(LIBXUL_DIST)/sdk/bin/xpt.py link
> firefox builds fine (but I don't think that it is proper fix).

This is actually a proper fix.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

6 years ago
Created attachment 526474 [details] [diff] [review]
fix pyxpt path

$(SDK_BIN_DIR)/xpt.py -> $(LIBXUL_DIST)/sdk/bin/xpt.py
Attachment #526474 - Flags: review+

Updated

6 years ago
Attachment #526474 - Attachment is patch: true
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Pushed in cedar:
http://hg.mozilla.org/projects/cedar/rev/b0217a5e665a

BTW, ojab, if you want to have your real name in the commit logs, you should use it on bugzilla or at least put it in your patches as the author. It goes without saying that you don't *have* to do that ;)
Assignee: nobody → ojab
Status: NEW → ASSIGNED
Component: Build Config → Build Config
Keywords: checkin-needed
OS: Linux → All
Product: Firefox → Core
QA Contact: build.config → build-config
Hardware: x86_64 → All
Whiteboard: [fixed in cedar]
Version: unspecified → Trunk
And by 'real', I mean "full".
I have to backout this patch because of a build failure. See this log:
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1303169782.1303170069.29887.gz#err0
Whiteboard: [fixed in cedar]
(Assignee)

Comment 6

6 years ago
Created attachment 526916 [details] [diff] [review]
fix pyxpt path

'ifdef LIBXUL_SDK', maybe?
Attachment #526474 - Attachment is obsolete: true
Attachment #526916 - Flags: review?(mh+mozilla)
Comment on attachment 526916 [details] [diff] [review]
fix pyxpt path

Ah I misread the previous patch. It was good as I read it, that is, with LIBXUL_DIST instead of LIBXUL_SDK. LIBXUL_DIST is always defined, and is either $LIBXUL_SDK or $MOZ_BUILD_ROOT/dist.
Attachment #526916 - Flags: review?(mh+mozilla) → review-
(Assignee)

Comment 8

6 years ago
Created attachment 526947 [details] [diff] [review]
fix pyxpt path

Now with LIBXUL_DIST.
Attachment #526916 - Attachment is obsolete: true
Attachment #526947 - Flags: review?(mh+mozilla)
Attachment #526947 - Flags: review?(mh+mozilla) → review+
Re-pushed in cedar:
http://hg.mozilla.org/projects/cedar/rev/150dcb7430d6
Whiteboard: [fixed in cedar]
Pushed:
http://hg.mozilla.org/mozilla-central/rev/150dcb7430d6

Thank you for this patch :)
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in cedar]
Target Milestone: --- → mozilla6
You need to log in before you can comment on or make changes to this bug.