Last Comment Bug 650480 - Building with gcc 4.6 uses symbols from libstdc++ 4.6
: Building with gcc 4.6 uses symbols from libstdc++ 4.6
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla6
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 643690
  Show dependency treegraph
 
Reported: 2011-04-16 03:18 PDT by Mike Hommey [:glandium]
Modified: 2012-01-02 02:37 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add libstdc++ 4.6 support to our compatibility hack (3.03 KB, patch)
2011-04-16 03:18 PDT, Mike Hommey [:glandium]
taras.mozilla: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-04-16 03:18:10 PDT
Created attachment 526478 [details] [diff] [review]
Add libstdc++ 4.6 support to our compatibility hack

This is the error that is triggered by the check from bug 643690:
    0x0297f865 0x00 20 GLIBCXX_3.4.15
Error: We don't want these libstdc++ symbol versions to be used

The root cause is that while libstdc++ 4.5 renamed some std::_List_node_base methods, libstdc++ 4.6 completely moved std::_List_node_base to std::__detail::_List_node_base, which is what these GLIBCXX_3.4.15 symbols we end up using are.
Comment 1 Frederic Bezies 2011-04-16 05:52:58 PDT
Worked perfectly here, on my archlinux 64 bits, with gcc 4.6.0.
Comment 2 Mike Hommey [:glandium] 2011-04-20 23:55:29 PDT
http://hg.mozilla.org/mozilla-central/rev/bf99d8e0734e

Note You need to log in before you can comment on or make changes to this bug.