Last Comment Bug 650543 - Rewrite the test for bug 419132 to make it sane, and re-enable it
: Rewrite the test for bug 419132 to make it sane, and re-enable it
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XBL (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla6
Assigned To: :Ehsan Akhgari
:
Mentors:
Depends on:
Blocks: 419132 FlakyTimeout
  Show dependency treegraph
 
Reported: 2011-04-16 12:56 PDT by :Ehsan Akhgari
Modified: 2011-04-19 10:55 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (2.73 KB, patch)
2011-04-16 12:57 PDT, :Ehsan Akhgari
jonas: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2011-04-16 12:56:30 PDT
The test for bug 419132 tries to reload the window in an infinite loop, with a 60 second timeout.  This is crazy, and the test has been disabled because of this (rightly so).

I have a patch which makes the test load 4 times, and then finishes.  Technically, two times should be enough (since the original test case needs to trigger the gc, which will happen some time in the future tests), but I decided to cut it some slack!
Comment 1 :Ehsan Akhgari 2011-04-16 12:57:07 PDT
Created attachment 526512 [details] [diff] [review]
Patch (v1)
Comment 2 Jonas Sicking (:sicking) PTO Until July 5th 2011-04-18 20:38:31 PDT
Comment on attachment 526512 [details] [diff] [review]
Patch (v1)

Could you also trigger a GC after every other load? There's code in the patch in bug 588990 which adds API to SpecialPowers to trigger a GC. Feel free to steal the implementation from there you also review it (not the whole patch, just the gc implementation).

r=me with that.

Note You need to log in before you can comment on or make changes to this bug.