NamedMap::remove hash horkage with BucketItem::prev

VERIFIED FIXED in mozilla0.9

Status

()

VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: markushuebner, Assigned: axel)

Tracking

({crash})

Trunk
mozilla0.9
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
When going to the url
http://www.world-direct.com/gia/test
with the build 2001011020 Mozilla crashes.
(Reporter)

Updated

18 years ago
Severity: normal → critical
Priority: -- → P2

Comment 1

18 years ago
<?xml version='1.0' encoding='iso-8859-1'?><?xml-stylesheet version='1.0'
type='text/xsl' href='GolfClubsOverview.xsl'?><sal_output version="1.0">
First line is this. Doesn't crash for me in 0.7 and 2001010904 win32.
(Reporter)

Comment 2

18 years ago
got the info on #transformiix that in xsl-sorting it releases an nsString 
that's null.
Component: Browser-General → XSLT
(Reporter)

Updated

18 years ago
Priority: P2 → --

Comment 3

18 years ago
not crashing cvs pull from today...
Assignee: asa → kvisco
QA Contact: doronr → kvisco
Does not crash for me on win2k/ build 2001010620

Comment 5

18 years ago
WORKSFORME
Platform: PC
OS: Windows 98
Mozilla Build: 2001010904

Marking WORKSFORME.

Reopen if this reoccurs in the latest nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
Just tried build 20010111 and it still crashes.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

18 years ago
Just to clear things up, what the original bug report fails to mention is that
you need to have the Transformiix XSLT module installed for the crash. If the
module is not installed, the XML file just loads and there's no crash. Markus,
please include more details in your bug reports.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

18 years ago
Sorry about that ... when I go to the page Mozilla just closes.
No error message or crash info at all!
(Assignee)

Comment 9

18 years ago
I don't think we can deal with this with the wrappers as they are, marking 
a dependency.
And of course, it's more a Peter issue than Keith, so re-assigning.
Markus, that's just who would work on it, not that work started. Then the bug
will change to ASSIGNED.

Axel
Assignee: kvisco → peter.vanderbeken
Severity: critical → normal
Depends on: 65237
Keywords: crash
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 10

18 years ago
find the reason for this crasher. When removing a BucketItem from the NamedMap,
we didn't care about prev.
Patch coming in a minute, checkin tomorrow.

Axel
... updating alot of components
Assignee: peter.vanderbeken → axel
No longer depends on: 65237
Summary: browser crashes → NamedMap::remove hash horkage with BucketItem::prev
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 11

18 years ago
Created attachment 22883 [details] [diff] [review]
fixing NamedMap, securing MozillaString wrapper
(Assignee)

Comment 12

18 years ago
checked in, r=peterv
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

18 years ago
Thank you Axel & Peter. You did a great job :)
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.