Last Comment Bug 650594 - REFTEST TEST-UNEXPECTED-PASS in modules/plugin/test/reftest/plugin-transform-1.html on Android
: REFTEST TEST-UNEXPECTED-PASS in modules/plugin/test/reftest/plugin-transform-...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla6
Assigned To: Phil Ringnalda (:philor, back in August)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-16 23:08 PDT by Phil Ringnalda (:philor, back in August)
Modified: 2011-04-18 08:55 PDT (History)
2 users (show)
philringnalda: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
reftest log (17.63 KB, text/plain)
2011-04-16 23:08 PDT, Phil Ringnalda (:philor, back in August)
no flags Details
Fix v.1 (17.63 KB, patch)
2011-04-16 23:10 PDT, Phil Ringnalda (:philor, back in August)
no flags Details | Diff | Splinter Review
actual fix v.1 (1.51 KB, patch)
2011-04-17 10:08 PDT, Phil Ringnalda (:philor, back in August)
roc: review+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor, back in August) 2011-04-16 23:08:36 PDT
Created attachment 526565 [details]
reftest log

Not sure what to make of this: since it's an unexpected-pass, we must !haveTestPlugin on Android, but it passes. The log isn't particularly helpful, since for some reason I don't understand, it only contains one image, rather than the two I'd expect from a comparison.
Comment 1 Phil Ringnalda (:philor, back in August) 2011-04-16 23:10:17 PDT
Created attachment 526566 [details] [diff] [review]
Fix v.1

But I'm not one to let my total lack of understanding get in the way of my calling it random.
Comment 2 :Ms2ger 2011-04-17 08:44:20 PDT
Comment on attachment 526566 [details] [diff] [review]
Fix v.1

This is the log, not a patch, I'm afraid.
Comment 3 Phil Ringnalda (:philor, back in August) 2011-04-17 10:08:19 PDT
Created attachment 526597 [details] [diff] [review]
actual fix v.1

Attachments are hard. Let's go shopping!
Comment 4 Phil Ringnalda (:philor, back in August) 2011-04-17 15:48:55 PDT
http://hg.mozilla.org/mozilla-central/rev/84a3ce6c67b1
Comment 5 Zack Weinberg (:zwol) 2011-04-18 08:55:43 PDT
An == test passes if the test and reference images are identical.  So, an *unexpected pass* on an == test means the two images are *supposed* to be identical, they normally *aren't* due to a known bug (or in this case a known unimplemented feature), but on this particular run they *were* identical.  (Enough negation for ya? :-) Anyway, under these conditions it doesn't bother dumping out both images, because they would be two copies of the same image.

Note You need to log in before you can comment on or make changes to this bug.