Closed Bug 650932 Opened 11 years ago Closed 11 years ago

Ability to edit comments

Categories

(Bugzilla :: Creating/Changing Bugs, enhancement)

x86
macOS
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 540

People

(Reporter: GRMrGecko, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 

I think adding the ability for admins to edit comments would good as I have made a bug report and forgot to add something to the comment and it would be easier to edit than it would be to explain, "No wait. You need to do this and forget the above comment." I think you can follow me here. If this has been suggested before, I am sorry. The only thing I found similar was bug 531269. I had to go into the database and modify the text manually to get it to be what I wanted. I noticed that you guys have a full text search table with the text in it as well, and was wondering if that adds to the space taken by the database and if adding a feature like this would be hard due to that table.

Reproducible: Always




I am using Bugzilla 4.1.1 from the snapshot and thought this would be a good addition as I came to a point where I needed it.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 540
I believe that admins should be able to edit any content on the website(comments included).
At http://thetermpapers.net/ it helped us to prevent spam.
(In reply to RicaeurMone from comment #2)
> I believe that admins should be able to edit any content on the
> website(comments included).
> At http://thetermpapers.net/ it helped us to prevent spam.

I agree with you there, but I think users should be able to edit their own comments (e.g. NOT other people's comments) and subsequently have a revision system that shows all changes made by the user publicly. I would like to edit my own comments (remember the guideline that says "no comment spamming?") but I don't see a way to do so, at least not on this site.
You need to log in before you can comment on or make changes to this bug.