Last Comment Bug 650935 - UrlCryptoKeyManager does not correctly translate base64 keys
: UrlCryptoKeyManager does not correctly translate base64 keys
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Safe Browsing (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal with 1 vote (vote)
: Firefox 20
Assigned To: Nikolay Bryskin
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-18 14:49 PDT by Mehdi Mulani [:mmm] (I don't check this)
Modified: 2014-05-27 12:25 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
UnUrlSafe fix (447 bytes, patch)
2011-08-18 18:13 PDT, Nikolay Bryskin
dcamp: review+
Details | Diff | Splinter Review

Description Mehdi Mulani [:mmm] (I don't check this) 2011-04-18 14:49:29 PDT
In unUrlSafe, we only translate the first instance of a "-" -> "+" and "_" -> "/". These replacements should be made global.

Appropriate section of code:
http://hg.mozilla.org/mozilla-central/diff/39d0829ed9e2/toolkit/components/url-classifier/content/url-crypto-key-manager.js

It looks like this piece of code is still used, not 100% sure though. Basing my judgement that this should be a global replace on the nsUrlClassifierUtils version at http://mxr.mozilla.org/mozilla-central/source/toolkit/components/url-classifier/nsUrlClassifierUtils.cpp#401
Comment 1 Nikolay Bryskin 2011-08-18 18:13:02 PDT
Created attachment 554277 [details] [diff] [review]
UnUrlSafe fix

Hi, here is the fix for this bug
Comment 2 Philip Chee 2012-12-24 01:37:39 PST
Hello Nikolay, do you require assistance in getting this patch checked-in to the tree?
Comment 3 Nikolay Bryskin 2012-12-24 02:14:26 PST
Yep, I think so. It emerged that it's more complicated process than I thought.
Comment 4 Philip Chee 2013-01-03 05:30:05 PST
>> Hello Nikolay, do you require assistance in getting this patch checked-in to the tree?
> Yep, I think so. It emerged that it's more complicated process than I thought.
Setting the checkin-needed flag.
Comment 5 Ryan VanderMeulen [:RyanVM] 2013-01-03 14:27:57 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/ef515efc6ff7

Thanks for the patch, Nikolay! And sorry for the horribly long delay :(
Comment 6 Ed Morley [:emorley] 2013-01-04 09:57:06 PST
https://hg.mozilla.org/mozilla-central/rev/ef515efc6ff7

Note You need to log in before you can comment on or make changes to this bug.