Closed Bug 65100 Opened 20 years ago Closed 20 years ago

[BeOS: Copy & Paste] implement nsClipboard

Categories

(Core :: XUL, defect, P3)

x86
BeOS
defect

Tracking

()

VERIFIED FIXED
mozilla0.9

People

(Reporter: toyoshim, Assigned: cls)

Details

Attachments

(7 files)

Currently nsClipboard for BeOS is not implemented. 
And now I'm implementing it. :)
Now copy'n paste of text/unicode in SetNativeClipboardData and GetNativeClipboardData
were implemented. But not text/html.
And in SetNativeClipboardData, we get always null data from mTransferable for any reason.
So copy operation can not work currently.
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Hi toyoshima,
because it has not checked in to CVS tree, it should not be RESOLVED/FIXED.

reopen this bug.
cc: me, cls, yannick
change severity to major.
Severity: normal → major
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Thank you for advices, Makoto!

I fixed implementation again.
(using text conversion function in nsString)

reassign to cls.
Assignee: toyoshim → cls
!     if ((B_OK == rc) && (NULL != data) && (0 != size)) {

1. someone doesn't like (const comparison variable) but that's kind of style.
2. you don't need ()s around those
3. please use nsnull over NULL
4. i prefer (size) over (size != 0) and (data) over (data != nsnull)

!   BMessage *msg;
!   nsresult rv = NS_ERROR_FAILURE;
! 
!   if (NULL != (msg = be_clipboard->Data())) {
why not:
!   BMessage *msg=be_clipboard->Data();
!   nsresult rv = NS_ERROR_FAILURE;
! 
!   if (msg) {

i'll try to attach a version based on these styles 
Keywords: patch, review
Status: UNCONFIRMED → NEW
Ever confirmed: true
I checked in a modified version of attach 22447.  The reason mTransferable
seemed to be always returning null was because you were never calling
nsPrimitive:CreateDataFromPrimitive() so the clipboard data was never being
assigned to your data variable. 

Thanks for the patch.  I'm leaving the bug open until nsClipboard is fully
implemented.
Keywords: patch, review
Priority: -- → P4
Target Milestone: --- → mozilla0.9
Thank you cls and timeless.
I made new patch.

This patch contain following.
1. fix of some mistaken coding styles.
2. bug fix (sometimes copyed string was broken.)
3. 'copy link location' work. (I delete QueryInterface().)
4. copy'n paste of text/html and others.
Priority: P4 → P3
Attached patch revised patchSplinter Review
22879 is revised of 22865.
22865 contain a bug that we can not copy from text box.
note: 22882 updates the nsClipboard.cpp part of 22879, but does not include the 
nsClipboard.h changes.
Checked in nsClipboard.h changes from attach 22879 and nsClipboard.cpp changes
from attach 22882.  Marking fixed.
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.