Last Comment Bug 651013 - a couple of layout/base mochitests should be moved to mochitest-chrome tests
: a couple of layout/base mochitests should be moved to mochitest-chrome tests
Status: RESOLVED FIXED
[specialpowers]
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Joel Maher ( :jmaher)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-18 19:31 PDT by Joel Maher ( :jmaher)
Modified: 2011-04-20 06:07 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
move two test files -> chrome tests (1.0) (18.47 KB, patch)
2011-04-18 19:45 PDT, Joel Maher ( :jmaher)
no flags Details | Diff | Splinter Review
move two test files -> chrome tests (2.0) (4.54 KB, patch)
2011-04-19 19:42 PDT, Joel Maher ( :jmaher)
roc: review+
Details | Diff | Splinter Review

Description Joel Maher ( :jmaher) 2011-04-18 19:31:32 PDT
in trying to get the layout/base/tests/test_* mochitests running with only specialPowers, I noticed that a couple test files were doing things that should really belong in mochitest-chrome:
 - test_bug370436.html
 - test_bug420499.xul

In addition there are some reftest style tests in test_reftests_with_caret.html which I am not sure should be in mochitest-plain.
Comment 1 Joel Maher ( :jmaher) 2011-04-18 19:45:21 PDT
Created attachment 526898 [details] [diff] [review]
move two test files -> chrome tests (1.0)

simple patch to move some tests from mochitest plain to chrome.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-04-19 04:43:47 PDT
Comment on attachment 526898 [details] [diff] [review]
move two test files -> chrome tests (1.0)

I think for moving tests to chrome you should get review from the original test author or reviewer, since they have the subject knowledge here.
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-04-19 15:18:18 PDT
This patch should use hg rename.
Comment 4 Joel Maher ( :jmaher) 2011-04-19 19:42:39 PDT
Created attachment 527180 [details] [diff] [review]
move two test files -> chrome tests (2.0)

updated with hg rename vs hg delete/add
Comment 5 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-04-19 19:57:31 PDT
Comment on attachment 527180 [details] [diff] [review]
move two test files -> chrome tests (2.0)

Thanks!

Note You need to log in before you can comment on or make changes to this bug.