Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 651048 - Connect to Sync popup is still displayed even if the app is already connected to Sync
: Connect to Sync popup is still displayed even if the app is already connected...
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 4.0
: ARM Android
: P2 normal (vote)
: Firefox 6
Assigned To: Wesley Johnston (:wesj)
: 661110 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2011-04-19 01:04 PDT by Cristian Nicolae (:xti)
Modified: 2011-07-14 21:34 PDT (History)
10 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---

Simple fix? (808 bytes, patch)
2011-05-04 11:03 PDT, Wesley Johnston (:wesj)
mark.finkle: review+
Details | Diff | Splinter Review

Description Cristian Nicolae (:xti) 2011-04-19 01:04:11 PDT
This issue is still reproducing on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:2.1.1)Gecko/20110415
Firefox/4.0.2pre Fennec/4.0.1
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1

Steps to reproduce:
1. Open Fennec App
2. Go to Preferences > Sync and tap on Connect button
3. Connect to Sync with valid creditentials
4. Go to about:firstrun
5. Tap on Sync Up

Expected result:
Connect to Sync popup should not be displayed if the app is already connected to Sync.

Actual result:
Connect to Sync popup is displayed after step 5. Even if the app is connecting to Sync after step 5 through the popup and the steps 4 and 5 are performed again, there will be the same result: Connect to Sync popup is displayed.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-04-19 05:58:05 PDT
Madhava - what should happen in this case? Should we show the awesomescreen (desktop tabs) or the preferences page or something else?
Comment 2 Wesley Johnston (:wesj) 2011-05-04 11:03:14 PDT
Created attachment 530084 [details] [diff] [review]
Simple fix?

Putting this up so that we have something. This attempts to open remote tabs when you click it. If you don't have sync set up, trying to open remote tabs will show the connect dialog. Otherwise, it shows remote tabs.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-04 12:49:58 PDT
Comment on attachment 530084 [details] [diff] [review]
Simple fix?

    function loadSync() {
>           let win = getChromeWin();
>+          win.BrowserUI.doCommand("cmd_remoteTabs");

Add a comment: // If Sync is not setup, we'll open the setup dialog. Otherwise, we show the remote tabs view
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-04 12:51:57 PDT
Somewhere, there is a different bug about showing a throbber while the remote tabs view does it's initial sync... it's bug 653146
Comment 5 Wesley Johnston (:wesj) 2011-05-06 09:53:05 PDT
Comment 6 Andreea Pod 2011-05-09 04:27:41 PDT
Verified fixed on build: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110508 Firefox/6.0a1 Fennec/6.0a1 
Device: LG Optimus 2X (Android 2.2)
Comment 7 Kevin Brosnan [:kbrosnan] 2011-06-01 08:24:06 PDT
*** Bug 661110 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.